hdu 5773 策略+最长上升子序列

Problem Description
?? gets an sequence S with n intergers(0 < n <= 100000,0<= S[i] <= 1000000).?? has a magic so that he can change 0 to any interger(He does not need to change all 0 to the same interger).?? wants you to help him to find out the length of the longest increasing (strictly) subsequence he can get.
 

Input
The first line contains an interger T,denoting the number of the test cases.(T <= 10)
For each case,the first line contains an interger n,which is the length of the array s.
The next line contains n intergers separated by a single space, denote each number in S.
 

Output
For each test case, output one line containing “Case #x: y”(without quotes), where x is the test case number(starting from 1) and y is the length of the longest increasing subsequence he can get.
 

Sample Input
  
  
2 7 2 0 2 1 2 0 5 6 1 2 3 3 0 0
 

Sample Output
  
  
Case #1: 5 Case #2: 5
Hint
In the first case,you can change the second 0 to 3.So the longest increasing subsequence is 0 1 2 3 5.
 

Author
FZU
 

Source

2016 Multi-University Training Contest 4


题意:给你一串数,其中包括0,并且0可以变为任何数

问修改后这串数字的最大上升序列的长度


思路:0是最有用,即使不能增加长度也可以保持不变,所以我们的策略就是把所有的0全用上,让所有数减去其前边出现0的个数(为0腾出空间),然后求修改后的数列的最长上升序列+0的个数,就是答案


ac代码:

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <iostream>
#include <string>
#include <map>
#include <queue>
using namespace std;
typedef long long ll;
typedef long double ld;
int n, m, d[maxn], g[maxn], a[maxn], kase = 0;
int main() {
    int T; scanf("%d", &T);
    while(T--) {
        scanf("%d", &n);
        for(int i = 1; i <= n; i++) {
            g[i] = INF;
            scanf("%d", &a[i]);
            cout<<a[i]<<" ";
        }
        cout<<endl;
        int num = 0, ans = 0;
        for(int i = 1; i <= n; i++) {
            if(a[i] == 0) {
                num++;
                continue;
            }
            a[i] -= num;
            int k = lower_bound(g+1, g+n+1, a[i]) - g;
            d[i] = k;
            g[k] = a[i];
            ans = max(ans, d[i]);
        }
        printf("Case #%d: %d\n", ++kase, ans+num);
    }
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值