ZOJ - 3623 - Battle Ships (01背包变形)

Battle Ships

Time Limit: 2 Seconds       Memory Limit: 65536 KB

Battle Ships is a new game which is similar to Star Craft. In this game, the enemy builds a defense tower, which has L longevity. The player has a military factory, which can produce N kinds of battle ships. The factory takes ti seconds to produce the i-th battle ship and this battle ship can make the tower loss li longevity every second when it has been produced. If the longevity of the tower lower than or equal to 0, the player wins. Notice that at each time, the factory can choose only one kind of battle ships to produce or do nothing. And producing more than one battle ships of the same kind is acceptable.

Your job is to find out the minimum time the player should spend to win the game.

Input

There are multiple test cases. 
The first line of each case contains two integers N(1 ≤ N ≤ 30) and L(1 ≤ L ≤ 330), N is the number of the kinds of Battle Ships, L is the longevity of the Defense Tower. Then the following N lines, each line contains two integers i(1 ≤ i ≤ 20) and li(1 ≤ li ≤ 330) indicating the produce time and the lethality of the i-th kind Battle Ships.

Output

Output one line for each test case. An integer indicating the minimum time the player should spend to win the game.

Sample Input
1 1
1 1
2 10
1 1
2 5
3 100
1 10
3 20
10 100

Sample Output
2
4
5


Author:  FU, Yujun
Contest:  ZOJ Monthly, July 2012
Submit     Status




思路:将时间翻转过来,让时间作为背包的容量来进行动态规划,,,


AC代码:

#include <cstdio>
#include <cstring>
#include <algorithm>
#define INF 0x3fffffff
using namespace std;

int t[105], l[105];
int dp[505];//dp[i]表示在i这个时间以内所造成的最大伤害 

int main() {
	int N, L;
	while(scanf("%d %d", &N, &L) != EOF) {
		for(int i = 1; i <= N; i++) {
			scanf("%d%d", &t[i], &l[i]);
		}
		
		memset(dp, 0, sizeof(dp));
		for(int i = 0; i <= 335; i++) {
			for(int j = 1; j <= N; j++) {
				dp[i + t[j]] = max(dp[i + t[j]], dp[i] + i * l[j] );
			}
		} 
		
		int ans = INF;
		for(int i = 0; i <= 335; i++) {
			if(dp[i] >= L && ans > i) ans = i;
		}
		printf("%d\n", ans);
	}
	return 0;
}













评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值