uva Simple calculations (数学推导)

16 篇文章 0 订阅

The Problem

There is a sequence of n+2 elements a0, a1,…, an+1 (n <= 3000; -1000 <=  ai 1000). It is known that ai = (ai–1 + ai+1)/2 – ci   for each i=1, 2, ..., n. You are given a0, an+1, c1, ... , cn. Write a program which calculates a1.

The Input

The first line is the number of test cases, followed by a blank line.

For each test case, the first line of an input file contains an integer n. The next two lines consist of numbers a0 and an+1 each having two digits after decimal point, and the next n lines contain numbers ci (also with two digits after decimal point), one number per line.

Each test case will be separated by a single line.

The Output

For each test case, the output file should contain a1 in the same format as a0 and an+1.

Print a blank line between the outputs for two consecutive test cases.

Sample Input

1150.5025.5010.15

Sample Output

27.85
 
给你a0,an+1的值,然后给你数列C,根据给的ai = (ai-1 + ai+1) / 2 - ci ,求出a1的值。
本来是变形一下式子叠加消除,也不是很方便。对于给的式子,可以变形得到ai+1=2*ai - ai-1 + 2*ci;
则ai= 2*ai-1 -ai-2 + 2*ci-1,带入上式可得ai+1= 3*ai - 2* ai-1 + 4*ci-1 + 2*ci; 依次进行下去可得
ai+1=(i+1)*a1 - i*a0 + (2*ci + 4*ci-1 + 6*ci-2 +...+ 2*i*c0) 把i变为n 变形可得
a1 = (an+1 + n*a0 - (2*cn + 4*cn-1 + .... + 2*n*c0) ) / (n+1)

#include <iostream>
#include <cstdio>
using namespace std;
double c[3010];
int main()
{
    int T;
    cin>>T;
    for(int j=1;j<=T;j++)
    {
        int n;
        cin>>n;
        double a0,an;
        cin>>a0>>an;
        double sum=0;
        for(int i=0;i<n;i++)
         {
             cin>>c[i];
             sum+=c[i]*2*(n-i);
         }
         double ans=(an+n*a0 - sum)/(n+1);
         printf("%.2lf\n",ans);
         if(j!=T)
            cout<<endl;
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值