Time Limit: 2000MS | Memory Limit: 65536K | |
Total Submissions: 13141 | Accepted: 3849 |
Description
Farmer John's N cows (1 ≤ N ≤ 100,000) share many similarities. In fact, FJ has been able to narrow down the list of features shared by his cows to a list of only K different features (1 ≤ K ≤ 30). For example, cows exhibiting feature #1 might have spots, cows exhibiting feature #2 might prefer C to Pascal, and so on.
FJ has even devised a concise way to describe each cow in terms of its "feature ID", a single K-bit integer whose binary representation tells us the set of features exhibited by the cow. As an example, suppose a cow has feature ID = 13. Since 13 written in binary is 1101, this means our cow exhibits features 1, 3, and 4 (reading right to left), but not feature 2. More generally, we find a 1 in the 2^(i-1) place if a cow exhibits feature i.
Always the sensitive fellow, FJ lined up cows 1..N in a long row and noticed that certain ranges of cows are somewhat "balanced" in terms of the features the exhibit. A contiguous range of cows i..j is balanced if each of the K possible features is exhibited by the same number of cows in the range. FJ is curious as to the size of the largest balanced range of cows. See if you can determine it.
Input
Lines 2.. N+1: Line i+1 contains a single K-bit integer specifying the features present in cow i. The least-significant bit of this integer is 1 if the cow exhibits feature #1, and the most-significant bit is 1 if the cow exhibits feature # K.
Output
Sample Input
7 3 7 6 7 2 1 4 2
Sample Output
4
把所有数的二进制按位相加存在sum[][]中,对于满足题意的i,j两行 ,即有:
sum[i][0]-sum[j][0] = sum[i][1]-sum[j][1]=.....=sum[i][k]-sum[j][k]
(即对于i,j两行,每种特性出现的次数相同,即是平衡的)
可以得到
sum[i][1]-sum[i][0] = sum[j][1]-sum[j][0]
sum[i][2]-sum[i][0] = sum[j][2]-sum[j][0]
.
.
sum[i][k]-sum[i][0] = sum[j][k]-sum[j][0]
所以对于对于得到的sum 减去任意一列的值(这里选的第一列),所得到的值中,完全相同的两行是平衡的
剩下的可以对这些二进制排下序,找到相同两行的最大差值
#include <cstdio>
#include <cstring>
#include <stdlib.h>
#include <algorithm>
#include <iostream>
#include <cmath>
#define N 100010
using namespace std;
int a[N],n,k;
int sum[N][31];
struct node
{
int s[31];
int b;
} q[N];
int cmp(const void *a,const void *b)
{
for(int i=1; i<=k; i++)
{
if( (*(node *)a).s[i] != (*(node *)b).s[i])
return (*(node *)a).s[i] - (*(node *)b).s[i];
}
return (*(node *)a).b - (*(node *)b).b;
}
bool flag(int j)
{
for(int i=1; i<=k; i++)
if( q[j].s[i] != q[j-1].s[i])
return false;
return true;
}
int main()
{
while(~scanf("%d%d",&n,&k))
{
for(int i=1; i<=n; i++)
scanf("%d",&a[i]);
for(int i=0; i<=k; i++)
sum[0][i]=0;
for(int i=1 ; i<=n; i++)
{
int t=a[i];
for(int j=1; j<=k; j++)
{
sum[i][j]+=sum[i-1][j]+t%2;
t=t/2;
}
}
for(int i=1; i<=k; i++)
q[0].s[i]=0;
for(int i=1; i<=n; i++)
{
for(int j=1; j<=k; j++)
q[i].s[j] = sum[i][j] - sum[i][1];
q[i].b=i;
}
qsort(q,n+1,sizeof(q[0]),cmp);
int ans=0;
int start=0,end=0;
for(int i=1; i<=n; i++)
{
if(flag(i))
{
end=i;
}
else
{
ans=max(ans,q[end].b - q[start].b);
start=i;
end=i;
}
}
ans=max(ans,q[end].b - q[start].b);
printf("%d\n",ans);
}
return 0;
}