Supermarket poj 1456 贪心+并查集优化

Language:
Supermarket
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 9512 Accepted: 4096

Description

A supermarket has a set Prod of products on sale. It earns a profit px for each product x∈Prod sold by a deadline dx that is measured as an integral number of time units starting from the moment the sale begins. Each product takes precisely one unit of time for being sold. A selling schedule is an ordered subset of products Sell ≤ Prod such that the selling of each product x∈Sell, according to the ordering of Sell, completes before the deadline dx or just when dx expires. The profit of the selling schedule is Profit(Sell)=Σ x∈Sellpx. An optimal selling schedule is a schedule with a maximum profit. 
For example, consider the products Prod={a,b,c,d} with (pa,da)=(50,2), (pb,db)=(10,1), (pc,dc)=(20,2), and (pd,dd)=(30,1). The possible selling schedules are listed in table 1. For instance, the schedule Sell={d,a} shows that the selling of product d starts at time 0 and ends at time 1, while the selling of product a starts at time 1 and ends at time 2. Each of these products is sold by its deadline. Sell is the optimal schedule and its profit is 80. 

Write a program that reads sets of products from an input text file and computes the profit of an optimal selling schedule for each set of products. 

Input

A set of products starts with an integer 0 <= n <= 10000, which is the number of products in the set, and continues with n pairs pi di of integers, 1 <= pi <= 10000 and 1 <= di <= 10000, that designate the profit and the selling deadline of the i-th product. White spaces can occur freely in input. Input data terminate with an end of file and are guaranteed correct.

Output

For each set of products, the program prints on the standard output the profit of an optimal selling schedule for the set. Each result is printed from the beginning of a separate line.

Sample Input

4  50 2  10 1   20 2   30 1

7  20 1   2 1   10 3  100 2   8 2
   5 20  50 10

Sample Output

80
185

Hint

The sample input contains two product sets. The first set encodes the products from table 1. The second set is for 7 products. The profit of an optimal schedule for these products is 185.

Source

题意:超市有n个商品,每个商品有利润p和保质期d,每天卖一种商品问怎么卖才能使利润最大,求出最大利润。

思路:贪心,先按照商品利润从大到小排序,选出利润大的开始卖,卖的时间就在保质期d当天,若当天已经有商品在卖了,就从d往前推 看哪一天可以卖该商品。

代码:

//没有并查集优化
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <string>
#include <map>
#include <stack>
#include <vector>
#include <set>
#include <queue>
#pragma comment (linker,"/STACK:102400000,102400000")
#define maxn 10005
#define MAXN 2005
#define mod 1000000009
#define INF 0x3f3f3f3f
#define pi acos(-1.0)
#define eps 1e-6
#define lson rt<<1,l,mid
#define rson rt<<1|1,mid+1,r
typedef long long ll;
using namespace std;

struct Node
{
    int p,d;
}node[maxn];

int n;
bool vis[maxn];

int cmp(Node a,Node b)
{
    return a.p>b.p;
}

int main()
{
    while (~scanf("%d",&n))
    {
        memset(vis,false,sizeof(vis));
        for (int i=0;i<n;i++)
            scanf("%d%d",&node[i].p,&node[i].d);
        sort(node,node+n,cmp);
        int ans=0,f=-1;
        for (int i=0;i<n;i++)
        {
            int d=node[i].d;
            while (vis[d])
                d--;
            if (d<=0) continue;
            vis[d]=true;
            ans+=node[i].p;
        }
        printf("%d\n",ans);
    }
    return 0;
}

并查集优化,在向前找哪一天能够卖时使用并查集。

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <string>
#include <map>
#include <stack>
#include <vector>
#include <set>
#include <queue>
#pragma comment (linker,"/STACK:102400000,102400000")
#define maxn 10005
#define MAXN 2005
#define mod 1000000009
#define INF 0x3f3f3f3f
#define pi acos(-1.0)
#define eps 1e-6
#define lson rt<<1,l,mid
#define rson rt<<1|1,mid+1,r
typedef long long ll;
using namespace std;

struct Node
{
    int p,d;
}node[maxn];

int n;
int father[maxn];

int cmp(Node a,Node b)
{
    return a.p>b.p;
}

void init()
{
    for (int i=0;i<=maxn;i++)
        father[i]=i;
}

int find_father(int x)
{
    if (x!=father[x])
        father[x]=find_father(father[x]);
    return father[x];
}

int main()
{
    while (~scanf("%d",&n))
    {
        for (int i=0;i<n;i++)
            scanf("%d%d",&node[i].p,&node[i].d);
        init();
        sort(node,node+n,cmp);
        int ans=0;
        for (int i=0;i<n;i++)
        {
            int d=node[i].d;
            int dd=find_father(d);
            if (dd<=0) continue;
            father[dd]=dd-1;
            ans+=node[i].p;
        }
        printf("%d\n",ans);
    }
    return 0;
}


  • 3
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值