UVa 10115 Automatic Editing

字符串题目就先告一段落了,又是在看balabala不知道在说些什么的英语。

算法也很简单,用了几个库函数就搞定了。本来还担心题里说的replace-by为空的特殊情况需要特殊处理,后来发现按一般情况处理也能A过去。

第一次RE是因为char t[]开小了。

对了,strstr()函数我也是第一次用,对这个函数不太了解的同学,召唤传送门!奋斗

C语言中字符串操作之 strstr()

题目大意:给几组要查找的和要替换的字符串,和一段text,进行查找替换。说白了就是word里面查找替换功能。

不过需要注意的一点就是Find被替换完以后可能会出现新的Find子串,即Find可能被替换多次。

Problem E: Automatic Editing

Source file:autoedit.{ccppjavapas}
Input file:autoedit.in
Output file:autoedit.out

Text-processing tools like awk and sed allow you to automatically perform a sequence of editing operations based on a script. For this problem we consider the specific case in which we want to perform a series of string replacements, within a single line of text, based on a fixed set of rules. Each rule specifies the string to find, and the string to replace it with, as shown below.

RuleFindReplace-by
1.banbab
2.bababe
3.anaany
4.ba bhind the g

To perform the edits for a given line of text, start with the first rule. Replace the first occurrence of the find string within the text by the replace-by string, then try to perform the same replacement again on the new text. Continue until the find string no longer occurs within the text, and then move on to the next rule. Continue until all the rules have been considered. Note that (1) when searching for a find string, you always start searching at the beginning of the text, (2) once you have finished using a rule (because thefind string no longer occurs) you never use that rule again, and (3) case is significant.

For example, suppose we start with the line

banana boat

and apply these rules. The sequence of transformations is shown below, where occurrences of a find string are underlined and replacements are boldfaced. Note that rule 1 was used twice, then rule 2 was used once, then rule 3 was used zero times, and then rule 4 was used once.

 BeforeAfter
banana boatbabana boat
babana boatbababa boat
bababa boatbeba boat
beba boatbehind the goat

The input contains one or more test cases, followed by a line containing only 0 (zero) that signals the end of the file. Each test case begins with a line containing the number of rules, which will be between 1 and 10. Each rule is specified by a pair of lines, where the first line is the find string and the second line is the replace-by string. Following all the rules is a line containing the text to edit. For each test case, output a line containing the final edited text.

Both find and replace-by strings will be at most 80 characters long. Find strings will contain at least one character, but replace-by strings may be empty (indicated in the input file by an empty line). During the edit process the text may grow as large as 255 characters, but the final output text will be less than 80 characters long.

The first test case in the sample input below corresponds to the example shown above.

Example input:

4
ban
bab
baba
be
ana
any
ba b
hind the g
banana boat
1
t
sh
toe or top
0

Example output:

behind the goat
shoe or shop
//#define LOCAL
#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;

char Find[11][85],  Replace[11][85];
char text[260];

int main(void)
{
	#ifdef LOCAL
		freopen("10115in.txt", "r", stdin);
	#endif
	int N;
	while(scanf("%d", &N) == 1 && N)
	{
		getchar();
		int i;
		for(i = 0; i < N; ++i)
		{
			gets(Find[i]);
			gets(Replace[i]);
		}
		memset(text, 0, sizeof(text));
		gets(text);
		
		char *s, t[260];//一开始开的85,然后RE了
		for(i = 0; i < N; ++i)
		{
			while(s = strstr(text, Find[i]))//一个Find[i]可能要被替换多次
			{
				strcpy(t, s + strlen(Find[i]));//把后面需要连接的字符串先暂存在t里面
				*s = '\0';
				//if(strlen(Replace[i]))// strlen(Replace[i]) == 0 按一般情况处理即可
				//{
					strcat(text, Replace[i]);//连接需要替换的字符串
					strcat(text, t);		//连接最后的小尾巴
				//}
				//else
					//strcat(text, t);
			}
		}

		cout << text << endl;
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值