hdu-1398 Square Coins(母函数)

Square Coins

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Problem Description
People in Silverland use square coins. Not only they have square shapes but also their values are square numbers. Coins with values of all square numbers up to 289 (=17^2), i.e., 1-credit coins, 4-credit coins, 9-credit coins, ..., and 289-credit coins, are available in Silverland.
There are four combinations of coins to pay ten credits:

ten 1-credit coins,
one 4-credit coin and six 1-credit coins,
two 4-credit coins and two 1-credit coins, and
one 9-credit coin and one 1-credit coin.

Your mission is to count the number of ways to pay a given amount using coins of Silverland.
 

Input
The input consists of lines each containing an integer meaning an amount to be paid, followed by a line containing a zero. You may assume that all the amounts are positive and less than 300.
 

Output
For each of the given amount, one line containing a single integer representing the number of combinations of coins should be output. No other characters should appear in the output.
 

Sample Input
  
  
2 10 30 0
 

Sample Output
  
  
1 4 27
题意:求用1 4 9~289(17*17)面值的硬币能组成各种面值n(1~300)的方法数
母函数问题: 母函数模板
#include<iostream>
#include<string.h>
using namespace std;
int num[330],c[330];
int n,m;
int main()
{
	int i,j,k;
	memset(num,0,sizeof(num));
	num[0]=1;
	for(k=1;k<=17;k++)
	{
		m=k*k;//硬币值
		memset(c,0,sizeof(c));
		for(i=m;i<=300;i+=m)
		for(j=300;j>=0;j--)
		{
			if(j+i<=300)
			c[j+i]+=num[j];//c数组保存该次方新增的参数
			//num[j]+=num[j];
		}
		for(m=1;m<=300;m++)
			num[m]+=c[m];//乘完后加入num中,num[m]保存该次方的参数,即合成m的解
	}
			while(cin>>n&&n)
				cout<<num[n]<<endl;
			return 0;


}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值