hdu 1398 Square Coins(母函数/完全背包)

这篇博客介绍了如何利用母函数解决HDU 1398 Square Coins问题,该问题涉及整数分解。博主分享了从一位大神的博客中学习的思路,并给出了代码及详细注释,强调理解三重循环的重要性。
摘要由CSDN通过智能技术生成

Square Coins

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 11418    Accepted Submission(s): 7827


Problem Description
People in Silverland use square coins. Not only they have square shapes but also their values are square numbers. Coins with values of all square numbers up to 289 (=17^2), i.e., 1-credit coins, 4-credit coins, 9-credit coins, ..., and 289-credit coins, are available in Silverland. 
There are four combinations of coins to pay ten credits: 

ten 1-credit coins,
one 4-credit coin and six 1-credit coins,
two 4-credit coins and two 1-credit coins, and
one 9-credit coin and one 1-credit coin. 

Your mission is to count the number of ways to pay a given amount using coins of Silverland.
 

Input
The input consists of lines each containing an integer meaning an amount to be paid, followed by a line containing a zero. You may assume that all the amounts are positive and less than 300.
 

Output
For each of the given amount, one line containing a single integer representing the number of combinations of coins should be output. No other characters should appear in the output. 
 

Sample Input
  
  
2 10 30 0
 

Sample Output
  
  
1 4 27
 

Source
题意:求用硬币组成n有多少种方案,硬币必须是平方数(1,4,9,...289)  n不会超过300 故硬币最大面值是289了

思路:关于母函数可以看这位大神的博客,我也是刚在这里学习来的。

http://blog.csdn.net/vsooda/article/details/7975485

这道题其实是在整数分解的模板上面改一下得来,求解过程中的三重循环一定要理解理解再理解,具体可以看我代码和注释。

代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
using namespace std;
int a[350],b[350];///a[i]数组表示当前拼出i的方案数,b数组也是一个意思,只不过a是最终结果,而b只保存当前这一次的结果
int main()
{
    int n;
    while(~scanf("%d",&n)&&n)
    {
        for(int i=0; i<=n; i++)///这里表示的是用1元硬币(无限个)拼出0~n元的方案数, 显然都是1种
        {
            a[i]=1;
            b[i]=0;
        }
        for(int i=2; i*i<=n; i++)///用i*i元硬币
        {
            for(int j=0; j<=n; j++)///枚举已有的0~n元硬币
                for(int k=0; k+j<=n; k+=i*i)///使用0个,1个...x个i*i元硬币(x*i*i+j<=n),这里的思想跟背包一样= =
                    b[k+j]+=a[j];///把结果累加
            for(int j=0; j<=n; j++)///更新结果
            {
                a[j]=b[j];
                b[j]=0;///置零,为下一次计算做准备
            }
        }
        printf("%d\n",a[n]);
        /*int dp[350];
        memset(dp,0,sizeof(dp));
        for(int i=0;i<=n;i++)
            dp[i]=1;
        for(int i=2;i*i<=n;i++)
            for(int j=i*i;j<=n;j++)
                dp[j]+=dp[j-i*i];
        printf("%d\n",dp[n]);*/
    }
    return 0;
}






  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值