Cow Contest(floyd+传递闭包)


Cow Contest

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 131072/65536K (Java/Other)
Total Submission(s) : 52   Accepted Submission(s) : 27
Problem Description

N (1 ≤ N ≤ 100) cows, conveniently numbered 1..N, are participating in a programming contest. As we all know, some cows code better than others. Each cow has a certain constant skill rating that is unique among the competitors.

The contest is conducted in several head-to-head rounds, each between two cows. If cow A has a greater skill level than cow B (1 ≤ A ≤ N; 1 ≤ B ≤ NA ≠ B), then cow A will always beat cow B.

Farmer John is trying to rank the cows by skill level. Given a list the results of M (1 ≤ M ≤ 4,500) two-cow rounds, determine the number of cows whose ranks can be precisely determined from the results. It is guaranteed that the results of the rounds will not be contradictory.

 

Input

* Line 1: Two space-separated integers: N and M
* Lines 2..M+1: Each line contains two space-separated integers that describe the competitors and results (the first integer, A, is the winner) of a single round of competition: A and B

 

Output

* Line 1: A single integer representing the number of cows whose ranks can be determined
 

 

Sample Input
   
   
5 5 4 3 4 2 3 2 1 2 2 5
 

Sample Output
   
   
2
 



#include<iostream>
using namespace std;
const int MAXN=100+5;
int map[MAXN][MAXN];

void floyd(int n)
{
	int i,j,k;
	for(k=1;k<=n;k++)
		for(i=1;i<=n;i++)
			for(j=1;j<=n;j++)		
				map[i][j]=map[i][j]||map[i][k]&&map[k][j];
}

int main()
{
	int n,m,i,j,u,v,cnt,num;
	while(cin>>n>>m)
	{
		num=0;
		//memset(map,0,sizeof(map));
		for(i=1;i<=n;i++)
			for(j=1;j<=n;j++)
				map[i][j]=map[j][i]=0;
		for(i=1;i<=m;i++)
		{
			cin>>u>>v;
			map[u][v]=1;
		}
		floyd(n);
		for(i=1;i<=n;i++)
		{
			for(cnt=0,j=1;j<=n;j++)
			{
				if(map[i][j])
					cnt++;
				if(map[j][i])
					cnt++;
			}
			if(cnt==n-1)
				num++;	
		}
		cout<<num<<endl;
	}
	return 0;	
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值