1023. Have Fun with Numbers (20)

102 篇文章 0 订阅
26 篇文章 0 订阅

1023. Have Fun with Numbers (20)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

Notice that the number 123456789 is a 9-digit number consisting exactly the numbers from 1 to 9, with no duplication. Double it we will obtain 246913578, which happens to be another 9-digit number consisting exactly the numbers from 1 to 9, only in a different permutation. Check to see the result if we double it again!

Now you are suppose to check if there are more numbers with this property. That is, double a given number with k digits, you are to tell if the resulting number consists of only a permutation of the digits in the original number.

Input Specification:

Each input file contains one test case. Each case contains one positive integer with no more than 20 digits.

Output Specification:

For each test case, first print in a line "Yes" if doubling the input number gives a number that consists of only a permutation of the digits in the original number, or "No" if not. Then in the next line, print the doubled number.

Sample Input:
1234567899
Sample Output:
Yes
2469135798
原数由0-9几个数组成,看这个数乘二以后是否也由同样个数的0-9的排列组合。

 评测结果

时间结果得分题目语言用时(ms)内存(kB)用户
7月30日 14:03答案正确201023C++ (g++ 4.7.2)1308datrilla

测试点

测试点结果用时(ms)内存(kB)得分/满分
0答案正确13083/3
1答案正确11802/2
2答案正确13082/2
3答案正确13042/2
4答案正确13082/2
5答案正确13083/3
6答案正确13083/3
7答案正确13083/3
#include<iostream>     
#include<string>
using namespace std;  
int main()
{ 
  int digits[10] = {0},index,c;
  string strn,doublestr;
  char tempc;
  cin >> strn; 
  for (index = strn.size(),c=0; index > 0; )
  {
    index--;
    digits[strn[index] - '0']++;
    c += (strn[index] - '0')*2;
    digits[c % 10]--;
    tempc = c % 10 + '0';
    doublestr = tempc + doublestr;
    c = c / 10;
  }
  if (0 == c)
  {
    for (index = 0; index < 10&&0==c; index++)
    {
      if (0 != digits[index])c = 1;
    }
  }
  else
  { 
    tempc = c+ '0';
    doublestr = tempc + doublestr;
  }
  if (0 == c)cout << "Yes" << endl;
  else cout << "No" << endl;
  cout << doublestr << endl;
  system("pause");   
  return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值