刷题记录-自测-4 Have Fun with Numbers (20 分)-c语言

该博客探讨了一个有趣的数学现象:将数字123456789双倍后,得到的数字仍然是由1到9的数字组成,只是排列顺序不同。作者通过编程实现了一个检查是否具有此特性的算法,接收一个不超过20位的正整数,判断其双倍后是否仅包含原数字的排列。博客中提到,代码在PTA平台上得分15分,作者期待找出未达到满分的原因。
摘要由CSDN通过智能技术生成

Notice that the number 123456789 is a 9-digit number consisting exactly the numbers from 1 to 9, with no duplication. Double it we will obtain 246913578, which happens to be another 9-digit number consisting exactly the numbers from 1 to 9, only in a different permutation. Check to see the result if we double it again!

Now you are suppose to check if there are more numbers with this property. That is, double a given number with k digits, you are to tell if the resulting number consists of only a permutation of the digits in the original number.

Input Specification:

Each input contains one test case. Each case contains one positive integer with no more than 20 digits.

Output Specification:

For each test case, first print in a line "Yes" if doubling the input number gives a number that consists of only a permutation of the digits in the original number, or "No" if not. Then in the next line, print the doubled number.

Sample Input:

1234567899

Sample Output:

Yes
2469135798

 本段代码在PTA判题系统只能得15分,具体问题目前我还没发现。希望知道这段代码问题的大神赐教!

#include <stdio.h>
#define max 20

int digit(long long n);

int main(int argc,char const argv[])
{
	//输入一个整数
	long long n,m,p;
	int a[max],b[max],i,j,k,d,t;
	scanf("%lld",&n);
	d=digit(n);
	p=n;
	m=2*n;
	int e[10],f[10];
	//初始化数组 
	for (i=0;i<10;i++){
		e[i]=0;
		f[i]=0;
	}
	int ret=0;//记录是否符合这一规律 
	//如果乘以2以后位数不变则继续判断 
	if (d==digit(m)){
		ret=1;//初始化符合 
		for (i=0;i<d;i++){
			a[i]=n%10;//将n用a数组存起来 
			n/=10;
		} 
		for (i=0;i<d;i++){
			b[i]=m%10;//将m用b数组存起来 
			m/=10;
		}
		
		t=0;//临时变量用来遍历存入的每一位数字 
		while (t!=d){
			e[a[t]]++;//分别遍历两个数组,将其中的数字个数存起来 
			f[b[t]]++;
			t++;
		}
		for (i=0;i<10;i++){
			if (e[i] != f[i]){
				ret=0;//如果不相等,就表示不符合 
				break;
			}
		}	 
	}
	//输出结果
	if (ret==1){
		printf("Yes\n");
	} else {
		printf("No\n");
	}
	printf("%lld",2*p);
	return 0;
}

//创建函数,数数字位数
int digit(long long n)
{
	int cnt=0;
	if (n==0){
		cnt=1;
	}
	while (n!=0){
		n/=10;
		cnt++;
	}

	return cnt;
 } 

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值