1037. Magic Coupon (25)

102 篇文章 0 订阅
29 篇文章 0 订阅

1037. Magic Coupon (25)

时间限制
100 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

The magic shop in Mars is offering some magic coupons. Each coupon has an integer N printed on it, meaning that when you use this coupon with a product, you may get N times the value of that product back! What is more, the shop also offers some bonus product for free. However, if you apply a coupon with a positive N to this bonus product, you will have to pay the shop N times the value of the bonus product... but hey, magically, they have some coupons with negative N's!

For example, given a set of coupons {1 2 4 -1}, and a set of product values {7 6 -2 -3} (in Mars dollars M$) where a negative value corresponds to a bonus product. You can apply coupon 3 (with N being 4) to product 1 (with value M$7) to get M$28 back; coupon 2 to product 2 to get M$12 back; and coupon 4 to product 4 to get M$3 back. On the other hand, if you apply coupon 3 to product 4, you will have to pay M$12 to the shop.

Each coupon and each product may be selected at most once. Your task is to get as much money back as possible.

Input Specification:

Each input file contains one test case. For each case, the first line contains the number of coupons NC, followed by a line with NC coupon integers. Then the next line contains the number of products NP, followed by a line with NP product values. Here 1<= NC, NP <= 105, and it is guaranteed that all the numbers will not exceed 230.

Output Specification:

For each test case, simply print in a line the maximum amount of money you can get back.

Sample Input:
4
1 2 4 -1
4
7 6 -2 -3
Sample Output:
43
两行中,每个数最多使用一次,上面的乘下面的加起来最大;我这里尝试使用deque,双向链表,其实使用两个一维数组,分别排好序,从左便开始,乘起来能大于0就加,否则从后面开始。

评测结果

时间结果得分题目语言用时(ms)内存(kB)用户
8月05日 12:32答案正确251037C++ (g++ 4.7.2)521332datrilla

测试点

测试点结果用时(ms)内存(kB)得分/满分
0答案正确130810/10
1答案正确14363/3
2答案正确13083/3
3答案正确13843/3
4答案正确5213323/3
5答案正确11803/3

#include<iostream>
#include<algorithm>
#include<deque>
using namespace std;
void readln(deque<int>*DQ)
{
  int goal,N;
  cin >> N;
  while (N--)
  {
    cin >> goal;
  (*DQ).push_back(goal);
    }
}
int getmost1(deque<int>*coupon, deque<int>*product, int sum)
{
  while(!coupon->empty() && !product->empty())
  {
    if (coupon->front()*product->front() > 0)sum += coupon->front()*product->front();
    else return sum;
    coupon->pop_front();
    product->pop_front();
  }
  return sum;
}
int getmost2(deque<int>*coupon, deque<int>*product, int sum)
{
  while (!coupon->empty() && !product->empty())
  {
    if (coupon->back()*product->back() > 0)sum += coupon->back()*product->back();
    else return sum;
    coupon->pop_back();
    product->pop_back();
  }
  return sum;
}
bool moreCMp(const int &a, const int&B){ return a > B; } 
int main()
{
  deque<int>coupon, product;
  int sum=0;
  readln(&coupon);
  readln(&product);
  sort(coupon.begin(), coupon.end(), moreCMp);
  sort(product.begin(), product.end(), moreCMp);
  sum = getmost1(&coupon, &product, sum);  
  sum = getmost2(&coupon, &product, sum);
  cout << sum << endl;
  system("pause");
  return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值