2018_1_31_Common permutation_字符串基础题

Common permutation
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 5786 Accepted: 1750

Description

Given two strings of lowercase letters, a and b, print the longest string x of lowercase letters such that there is a permutation of x that is a subsequence of a and there is a permutation of x that is a subsequence of b.

Input

Input consists of pairs of lines. The first line of a pair contains a and the second contains b. Each string is on a separate line and consists of at most 1,000 lowercase letters.

Output

For each subsequent pair of input lines, output a line containing x. If several x satisfy the criteria above, choose the first one in alphabetical order.

Sample Input

pretty
women
walking
down
the
street

Sample Output

e
nw
et

Source

The UofA Local 1999.10.16
#include<iostream>
#include<algorithm>
#include<fstream>
#include<map>
#include<set>
#include<string>
#include<stack>
#include<cctype>
#include<cstring>
using namespace std;

ofstream out;
const int N=1000+10;
char a[N];
char b[N];
int main(){
	while(gets(a)&&gets(b)){
		sort(a,a+strlen(a));
		sort(b,b+strlen(b));
		for(int i=0,j=0;i<strlen(a)&&j<strlen(b);){
			if(a[i]==b[j]){
				putchar(a[i]);
				i++;
				j++;
			}else if(a[i]<b[j])i++;
			else j++;
		}
		cout<<endl;
	}
    return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值