2018_2_8_Grandpa is Famous_词典_排序

12 篇文章 0 订阅
6 篇文章 0 订阅
Language:
Grandpa is Famous
Time Limit: 2000MS Memory Limit: 30000K
Total Submissions: 8846 Accepted: 4348

Description

The whole family was excited by the news. Everyone knew grandpa had been an extremely good bridge player for decades, but when it was announced he would be in the Guinness Book of World Records as the most successful bridge player ever, whow, that was astonishing!
The International Bridge Association (IBA) has maintained, for several years, a weekly ranking of the best players in the world. Considering that each appearance in a weekly ranking constitutes a point for the player, grandpa was nominated the best player ever because he got the highest number of points.
Having many friends who were also competing against him, grandpa is extremely curious to know which player(s) took the second place. Since the IBA rankings are now available in the internet he turned to you for help. He needs a program which, when given a list of weekly rankings, finds out which player(s) got the second place according to the number of points.

Input

The input contains several test cases. Players are identified by integers from 1 to 10000. The first line of a test case contains two integers N and M indicating respectively the number of rankings available (2 <= N <= 500) and the number of players in each ranking (2 <= M <= 500). Each of the next N lines contains the description of one weekly ranking. Each description is composed by a sequence of M integers, separated by a blank space, identifying the players who figured in that weekly ranking. You can assume that:
  • in each test case there is exactly one best player and at least one second best player,
  • each weekly ranking consists of M distinct player identifiers.

The end of input is indicated by N = M = 0.

Output

For each test case in the input your program must produce one line of output, containing the identification number of the player who is second best in number of appearances in the rankings. If there is a tie for second best, print the identification numbers of all second best players in increasing order. Each identification number produced must be followed by a blank space.

Sample Input

4 5
20 33 25 32 99
32 86 99 25 10
20 99 10 33 86
19 33 74 99 32
3 6
2 34 67 36 79 93
100 38 21 76 91 85
32 23 85 31 88 1
0 0

Sample Output

32 33
1 2 21 23 31 32 34 36 38 67 76 79 88 91 93 100

Source

#include<iostream>
#include<cstdio>
#include<cstring>
#include<string> 
#include<cctype>
#include<vector>
#include<algorithm> 
#include<map>
using namespace std;

map<int,int> mi;
#define mii map<int,int>

struct AA{
	int key;
	int t;
	AA(int k,int tt):key(k),t(tt){}
};

bool cmp(AA a,AA b){
	if(a.t==b.t)return a.key<b.key;
	return a.t>b.t;
}

int main(){
	int n,m;
	int t;
	while(scanf("%d%d",&n,&m),n||m){
		mi.clear();
		for(int i=0;i<n;i++)
		for(int j=0;j<m;j++){
			scanf("%d",&t);
			mi[t]++;
		}
		vector<AA> v;
		for(mii::iterator it=mi.begin();it!=mi.end();it++)
		v.push_back(AA((*it).first,(*it).second));
		sort(v.begin(),v.end(),cmp);
		int i=1;
		for(;v[i].t==v[i+1].t;i++)
		printf("%d ",v[i].key);
		printf("%d\n",v[i].key);
	}
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
可以通过左孩子右兄弟二叉树来实现家族家谱的表示。在左孩子右兄弟二叉树中,每个节点有两个指针,一个指向其第一个孩子节点,另一个指向其右兄弟节点。 我们可以定义一个Person类来表示家族中的每个人,每个Person对象包含以下属性: - name:姓名 - gender:性别 - father:父亲节点 - firstChild:第一个孩子节点 - rightSibling:右兄弟节点 然后,我们可以通过构建Person对象之间的左孩子右兄弟二叉树来表示家族家谱。具体实现过程可以参考以下Java代码: ```java public class Person { private String name; private String gender; private Person father; private Person firstChild; private Person rightSibling; // 构造函数 public Person(String name, String gender) { this.name = name; this.gender = gender; this.father = null; this.firstChild = null; this.rightSibling = null; } // 添加子女节点 public void addChild(Person child) { child.father = this; if (this.firstChild == null) { this.firstChild = child; } else { Person sibling = this.firstChild; while (sibling.rightSibling != null) { sibling = sibling.rightSibling; } sibling.rightSibling = child; } } // 获取父亲节点 public Person getFather() { return this.father; } // 获取第一个孩子节点 public Person getFirstChild() { return this.firstChild; } // 获取右兄弟节点 public Person getRightSibling() { return this.rightSibling; } } ``` 这样,我们就可以通过创建Person对象之间的左孩子右兄弟二叉树来表示家族家谱。例如,下面的代码表示了一个家族家谱: ```java Person grandpa = new Person("Grandpa", "Male"); Person dad = new Person("Dad", "Male"); Person uncle = new Person("Uncle", "Male"); Person son1 = new Person("Son1", "Male"); Person son2 = new Person("Son2", "Male"); Person daughter = new Person("Daughter", "Female"); grandpa.addChild(dad); grandpa.addChild(uncle); dad.addChild(son1); dad.addChild(son2); dad.addChild(daughter); ``` 其中,Grandpa节点是根节点,Dad和Uncle是Grandpa的子节点,Son1、Son2、Daughter是Dad的子节点。通过遍历这棵左孩子右兄弟二叉树,我们就可以输出家族家谱。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值