时间限制: 1 Sec 内存限制: 128 MB
[提交] [状态]
题目描述
Takahashi has N sticks that are distinguishable from each other. The length of the i-th stick is Li.
He is going to form a triangle using three of these sticks. Let a, b, and c be the lengths of the three sticks used. Here, all of the following conditions must be satisfied:
·a<b+c
·b<c+a
·c<a+b
How many different triangles can be formed? Two triangles are considered different when there is a stick used in only one of them.
Constraints
·All values in input are integers.
·3≤N≤2×10^3
·1≤Li≤10^3
输入
Input is given from Standard Input in the following format:
N
L1 L2 … LN
输出
Print the number of different triangles that can be formed.
样例输入 Copy
【样例1】
4
3 4 2 1
【样例2】
3
1 1000 1
【样例3】
7
218 786 704 233 645 728 389
样例输出 Copy
【样例1】
1
【样例2】
0
【样例3】
23
提示
样例1解释
Only one triangle can be formed: the triangle formed by the first, second, and third sticks.
题目大意是在给定的n个数中任选三个,求能够组成多少个不同的三角形。
常规方法是利用三重循环遍历数组,判断满足三个不等式的数据有多少组,这种算法的时间复杂度为O(n3),题目给定的数据一定会超时(O(n3)算法能解决的数据范围在n<300),因此要对算法进行优化,结合题目的数据范围,可以优化到n2logn(估算的数量级为1e7),见到“logn”的字眼,可以尝试二分法,还真别说,二分法确实能AC这道题。
首先要对数据进行降序排序。构成三角形的条件是任意两边之和大于第三边,设存在a,b,c三条边,不妨假设a>b>c(对应于降序排序,这一点很关键),由a>b得a+c>b+c>b,由a>c得a+b>c+b>c,显然只需满足b+c>a(1)。因此题目就变成了求满足(1)式的数据共有多少组。我们可以先确定最大的数,然后在最大的数后面确定次大的数(不一定和最大的数相邻),最后二分确定最小的数。由于数据是降序排列,在确定a和b的情况下,c的下标越小,c越大越容易满足(1)式,随着c的下标的增大,c减小,可能存在一个临界点,在这个下标往后不能满足(1)式,因此二分的作用是找到满足(1)式的最大的下标。理解了这个原理,二分的代码中区间的移动就不难确定。
#include<stdio.h>
#include<stdlib.h>
int cmp(const void*a,const void*b)
{
return *(int*)b-*(int*)a;
}
int l[2005];
int main()
{
int n;
int i;
int j;
int left;
int right;
int mid;
int cnt=0;
scanf("%d",&n);
for(i=0;i<=n-1;i++)
{
scanf("%d",&l[i]);
}
qsort(l,n,sizeof(int),cmp);//降序排序
for(i=0;i<=n-3;i++)
{
for(j=i+1;j<=n-2;j++)
{
left=j+1;
right=n-1;
while(left<=right)
{
mid=(left+right)/2;
if(l[i]<l[j]+l[mid])
{
cnt+=mid-left+1;//每二分一次,cnt变量记下满足要求的个数,根据前面的分析,满足要求的数一定在mid所在下标的左侧
left=mid+1;
}
else right=mid-1;
}
}
}
printf("%d",cnt);
return 0;
}
/**************************************************************
Result: 正确
Time:133 ms
Memory:1128 kb
****************************************************************/