1065 A+B and C (64bit) (20分)*注意溢出!

Given three integers A, B and C in [−2​63​​,2​63​​], you are supposed to tell whether A+B>C.

Input Specification:

The first line of the input gives the positive number of test cases, T (≤10). Then T test cases follow, each consists of a single line containing three integers A, B and C, separated by single spaces.

Output Specification:

For each test case, output in one line Case #X: true if A+B>C, or Case #X: false otherwise, where X is the case number (starting from 1).

Sample Input:

3
1 2 3
2 3 4
9223372036854775807 -9223372036854775808 0

 

Sample Output:

Case #1: false
Case #2: true
Case #3: false

部分AC代码(自己写的):

#include<bits/stdc++.h>
using namespace std;
int main(){
    long long int a,b,c;
    int t;
    scanf("%d",&t);
    for(int i=1;i<=t;i++){
        scanf("%lld%lld%lld",&a,&b,&c);
        printf("Case #%d: %s\n",i,(a+b>c)?"true":"false");
    }
    return 0;
}

不明白哪儿错了。。。

AC代码(算法笔记):

#include<bits/stdc++.h>
using namespace std;
int main(){
    long long int a,b,c;
    int t;
    scanf("%d",&t);
    for(int i=1;i<=t;i++){
        scanf("%lld%lld%lld",&a,&b,&c);
        long long res=a+b;
        bool flag;
        if(a>0&&b>0&&res<0)flag=true;//正溢出
        else if(a<0&&b<0&&res>=0)flag=false;//负溢出
        else if(res>c)flag=true;
        else flag=false;
        printf("Case #%d: %s\n",i,(flag)?"true":"false");
    }
    return 0;
}

!!注意!!

由于long long 的范围是[-2^63,2^63),因此题中给出的两个整数相加有可能会溢出(正溢出或者负溢出),直接进行大小判断会造成错误(如果两个正数之和等于负数或者两个负数之和等于正数,那么就是溢出)。对于溢出后的具体范围,可以进行如下分析:

1.A+B>=2^63,显然这时和大于C,但A+B会因超过long long 的正向最大值而发生溢出。由于题目给定的A和B最大均为2^63-1,故A+B最大值为2^64-2,因此使用long long 存储正溢出后的值的区间为[-2^63,-2](由(2^64-2)%2=-2可得右边界)。所以当A>0,B>0,A+B<0时为正溢出,输出true。

2.A+B<-2^63,显然这时和小于C,但A+B会因超过long long 的负向最小值而发生溢出。由于题目给定的A和B最小均为-2^63,故A+B最小值为-2^64,因此使用long long 存储负溢出后的值的区间为[0,2^63)(由(-2^64)%2^64=0可得左边界)。所以当A<0,B<0,A+B>=0时为负溢出,输出false。

3.没有溢出的情况下,该咋着咋着。

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值