Red and Black(DFS)

11 篇文章 0 订阅
6 篇文章 0 订阅

Description

There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles. 

Write a program to count the number of black tiles which he can reach by repeating the moves described above. 

Input

The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20. 

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows. 

'.' - a black tile 
'#' - a red tile 
'@' - a man on a black tile(appears exactly once in a data set) 
The end of the input is indicated by a line consisting of two zeros. 

Output

For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).

Sample Input

6 9
....#.
.....#
......
......
......
......
......
#@...#
.#..#.
11 9
.#.........
.#.#######.
.#.#.....#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#.......#.
.#########.
...........
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
...@...
###.###
..#.#..
..#.#..
0 0

Sample Output

45
59
6
13

解题思路:

题目大意就是一个人只能走黑格子不能走红格子,且只能上下左右走,最初站在“@”地方,问有多少黑格子他可以走到。简单的DFS问题,又一个不需要考虑回溯的水题。

AC代码:

#include <iostream>
#include <cstdio>
using namespace std;
const int maxn = 30;
int w, h, count = 0;
int dir[4][2] = {{1,0},{0,1},{-1,0},{0,-1}};  // 二维数组定义四个方向
char map[maxn][maxn];
void Dfs(int x, int y)
{
    map[x][y] = '#';    // 走过的地方标记为红格子
    for(int i = 0; i < 4; i++)
    {
        int a = x + dir[i][0];
        int b = y + dir[i][1];
        if(a >= 0 && a < h && b >= 0 && b < w && map[a][b] == '.')
        {
            count++;
            Dfs(a,b);
        }
    }
}
int main()
{

    while(scanf("%d%d", &w, &h))
    {
        count = 0;
        int x, y;
        if(w == 0 && h == 0)
            break;
        getchar();
        for(int i = 0; i < h; i++)
        {
            for(int j = 0; j < w; j++)
            {
                scanf("%c", &map[i][j]);
                if(map[i][j] == '@')    // 找出起点
                {
                    x = i;
                    y = j;
                }
            }
            getchar();
        }
        Dfs(x, y);
        printf("%d\n",++count);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值