Japan(树状数组)

Description

Japan plans to welcome the ACM ICPC World Finals and a lot of roads must be built for the venue. Japan is tall island with N cities on the East coast and M cities on the West coast (M <= 1000, N <= 1000). K superhighways will be build. Cities on each coast are numbered 1, 2, ... from North to South. Each superhighway is straight line and connects city on the East coast with city of the West coast. The funding for the construction is guaranteed by ACM. A major portion of the sum is determined by the number of crossings between superhighways. At most two superhighways cross at one location. Write a program that calculates the number of the crossings between superhighways.

Input

The input file starts with T - the number of test cases. Each test case starts with three numbers – N, M, K. Each of the next K lines contains two numbers – the numbers of cities connected by the superhighway. The first one is the number of the city on the East coast and second one is the number of the city of the West coast.

Output

For each test case write one line on the standard output: 
Test case (case number): (number of crossings)

Sample Input

1
3 4 4
1 4
2 3
3 2
3 1

Sample Output

Test case 1: 5

解题思路:

题目大意是两边分别有多个城市,将两边的城市相连且每两条路的交点都不同,问有多少个交点。本质就是求逆序对。道路相连后,把一边的城市从小到大排个序,另一边的城市求逆序对即可。因为只要城市编号小于前面的编号则一定和前面的每条道路都有一个交点。本题有一点需要注意,我也就是在这个地方WA了四发的。虽然两边城市分别最多只有1000个,但连接方案种类可以达到1000*1000,所以记录方案的数组千万不要只开了1000多。还有最后的答案可能会超int范围,答案得用Int64存储。至于树状数组是如何求出逆序对的,这里就不过多阐述,网上讲的很清楚。

AC代码:

#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cstring>
using namespace std;
const int maxn = 1005;
__int64 c[maxn];
struct node
{
    int a, b;
}p[maxn * maxn];
bool cmp(node v,node s)
{
    if(v.a == s.a)
        return v.b < s.b;
    return v.a < s.a;
}
int lowbit(int a)
{
    return a & (-a);
}
void Update(int a)
{
    while(a < maxn)
    {
        c[a] += 1;
        a += lowbit(a);
    }
}
__int64 Sum(int a)
{
    __int64 sum = 0;
    while(a > 0)
    {
        sum += c[a];
        a -= lowbit(a);
    }
    return sum;
}
int main()
{
    int t, n, m, k, count = 0;
    __int64 ans;
    scanf("%d", &t);
    while(t--)
    {
        ans = 0;
        memset(c, 0, sizeof(c));
        scanf("%d%d%d", &n, &m, &k);
        for(int i = 0; i < k; i++)
            scanf("%d%d", &p[i].a, &p[i].b);
        sort(p , p + k, cmp);
        for(int i = 0; i < k; i++)
        {
            ans += i - Sum(p[i].b);
            Update(p[i].b);
        }
        printf("Test case %d: %I64d\n", ++count, ans);
    }
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值