POJ Tautology

3 篇文章 0 订阅
Tautology
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 12751 Accepted: 4861

Description

WFF 'N PROOF is a logic game played with dice. Each die has six faces representing some subset of the possible symbols K, A, N, C, E, p, q, r, s, t. A Well-formed formula (WFF) is any string of these symbols obeying the following rules:

  • p, q, r, s, and t are WFFs
  • if w is a WFF, Nw is a WFF
  • if w and x are WFFs, Kwx, Awx, Cwx, and Ewx are WFFs.
The meaning of a WFF is defined as follows:
  • p, q, r, s, and t are logical variables that may take on the value 0 (false) or 1 (true).
  • K, A, N, C, E mean and, or, not, implies, and equals as defined in the truth table below.
Definitions of K, A, N, C, and E
     w  x  Kwx  Awx   Nw  Cwx  Ewx
  1  1  1  1   0  1  1
  1  0  0  1   0  0  0
  0  1  0  1   1  1  0
  0  0  0  0   1  1  1

tautology is a WFF that has value 1 (true) regardless of the values of its variables. For example, ApNp is a tautology because it is true regardless of the value of p. On the other hand, ApNq is not, because it has the value 0 for p=0, q=1.

You must determine whether or not a WFF is a tautology.

Input

Input consists of several test cases. Each test case is a single line containing a WFF with no more than 100 symbols. A line containing 0 follows the last case.

Output

For each test case, output a line containing tautology or not as appropriate.

Sample Input

ApNp
ApNq
0

Sample Output

tautology
not
#include <iostream>

using namespace std;

const int maxn = 105;
char str[maxn];
int flag[10];
int start;
int judge()
{
    int p,q;
    switch(str[++start])
    {
      case 'K': p = judge(); q = judge();return (p&&q);
      case 'A': p = judge(); q = judge();return (p||q);
      case 'N': return (!judge());
      case 'C': p = judge(); q = judge();return (!p||q);
      case 'E': return (judge() == judge());
      default : return (flag[str[start] - 'p']);
    }

}
int main()
{
    while(cin>>str)
    {
        if(str[0] == '0')
            break;
        int ans = 1;
        for(int i=0;i<2;i++)
        {
            flag[0] = i;
            for(int j=0;j<2;j++)
            {
                flag[1] = j;
                for(int k=0;k<2;k++)
                {
                flag[2] = k;
                for(int s=0;s<2;s++)
                {
                    flag[3] = s;
                }
                for(int t=0;t<2;t++)
                {
                    flag[4] = t;
                    start = -1;
                    ans = (ans&&judge());
                    if(!ans)
                        break;
                }
                }
            }
        }
        if (!ans)cout<<"not"<<"\n";
        else      cout<<"tautology"<<"\n";
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Usher_Ou

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值