ACboy needs your help

题目链接: http://acm.hdu.edu.cn/showproblem.php?pid=1712 

ACboy needs your help


Problem Description
ACboy has N courses this term, and he plans to spend at most M days on study.Of course,the profit he will gain from different course depending on the days he spend on it.How to arrange the M days for the N courses to maximize the profit?
 

Input
The input consists of multiple data sets. A data set starts with a line containing two positive integers N and M, N is the number of courses, M is the days ACboy has.
Next follow a matrix A[i][j], (1<=i<=N<=100,1<=j<=M<=100).A[i][j] indicates if ACboy spend j days on ith course he will get profit of value A[i][j].
N = 0 and M = 0 ends the input.
 

Output
For each data set, your program should output a line which contains the number of the max profit ACboy will gain.
 

Sample Input
  
  
2 2 1 2 1 3 2 2 2 1 2 1 2 3 3 2 1 3 2 1 0 0
 

Sample Output
  
  
3 4 6

题意
n表示课程数量, 表示天数。接着是n*m的矩阵,矩阵第 A[i][j] 表示课程i花费j天所得利益。求在所花时间不超过m天的情况下如何上课,获取最大利益。
联系0-1背包问题,差别就是这里每个课程最多只能上一次,即矩阵中每行要么取一个要么不取。------分组背包问题。
分组背包问题:
即有N件物品和一个容量为V的背包,第i件物品的重量是c[i],价值是w[i]。这些物品被划分为若干组,每组中物品互相冲突,最多选择一件。求解将哪些物品装入背包使得这些物品的重量总和不超过背包容量,且价值总和最大。
算法:
问题变成了每组物品有若干种策略:是选择本组的某一件呢,还是一件都不选?也就是说设f[k][v]表示前k组物品花费费用v能取得的最大权值。

代码:

#include<iostream>
using namespace std;
 
int map[101][101];//存放输入的数据
int f[101][101];//存放获得最大值
 
int Max( int a , int b )
{   
      return a > b ?  a : b;    
}
 
int DP(int N , int M)
{   
      memset(f,0,sizeof(f));   
      for( int i = 1 ; i <= N ; i ++ )   
      {       
           for( int j = 1 ; j <= M ; j++  )
           {              
                 for( int  k = M ; k >= j ; k-- )          
                 {            
                      f[i][k] = Max( f[i][k] ,f[i-1][k] );             
                      f[i][k] = Max( f[i][k] ,f[i-1][k-j] + map[i][j] );
                 }
           }              
      }   
      return f[N][M];
}
 
int main()
{   
      int N ,M ;   
      while( scanf("%d%d",&N,&M), N||M )   
      {       
           for( int i = 1 ; i <= N; i++ )           
                 for( int j = 1 ; j <= M ; j++ )            
                      scanf( "%d" ,&map[i][j] );       
           printf( "%d\n", DP( N ,M ) );         
      }   
      return 0;   
}





评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值