The Suspects

The Suspects
Description
Severe acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. To minimize transmission to others, the best strategy is to separate the suspects from others. 
In the Not-Spreading-Your-Sickness University (NSYSU), there are many student groups. Students in the same group intercommunicate with each other frequently, and a student may join several groups. To prevent the possible transmissions of SARS, the NSYSU collects the member lists of all student groups, and makes the following rule in their standard operation procedure (SOP). 
Once a member in a group is a suspect, all members in the group are suspects. 
However, they find that it is not easy to identify all the suspects when a student is recognized as a suspect. Your job is to write a program which finds all the suspects.

Input

The input file contains several cases. Each test case begins with two integers n and m in a line, where n is the number of students, and m is the number of groups. You may assume that 0 < n <= 30000 and 0 <= m <= 500. Every student is numbered by a unique integer between 0 and n−1, and initially student 0 is recognized as a suspect in all the cases. This line is followed by m member lists of the groups, one line per group. Each line begins with an integer k by itself representing the number of members in the group. Following the number of members, there are k integers representing the students in this group. All the integers in a line are separated by at least one space. 
A case with n = 0 and m = 0 indicates the end of the input, and need not be processed.

Output

For each case, output the number of suspects in one line.

Sample Input

100 4
2 1 2
5 10 13 11 12 14
2 0 1
2 99 2
200 2
1 5
5 1 2 3 4 5
1 0
0 0

Sample Output

4
1
1
题意:需找SARS病毒的感染者嫌疑人数,与感染者0号同学有同组关系的都为嫌疑人,求所有和0号在一个集合的有多少人
题解:社团有num个孩子,即在num[]存储该集合中元素个数,并在集合 合并时更新num[]即可,第一个孩子不处理,从第二个孩子起,和上个孩子合并,这样就完成了他们的合并。然后找出0所在的集合的根节点x,因此,num[x]就是answer了
#include<iostream>
#include<algorithm>
using namespace std;
int set[30005];
int num[30005];
void Init_set(int n){
	for(int i=0;i<n;i++){
		//set[]存储节点的父节点
		set[i]=i;
		//num[]存储节点所在集合元素的个数
		num[i]=1;
	}	
}
//查找根节点 
int find(int x){
	int r=x;
	while(set[r]!=r)
		r=set[r];
	return r;
}
//并查集函数 
void merge(int a,int b){
	a=find(a);
	b=find(b);
	//如果两个元素在同一个集合则不需要合并
	if(a==b)
		return;
	//将小集合合并到大集合中,更新集合个数 
	if(num[a]>=num[b]){
		num[a]+=num[b];
		set[b]=a;
	}
	else{
		num[b]+=num[a];
		set[a]=b;
	}
}
int main(){
	int n;
	int m;
	int keep;
	int a;
	int b;
	int root;
	while(1){
		cin>>n>>m;
		if(n==0&&m==0)
			break;
		Init_set(n);
		for(int i=0;i<m;i++){ 
			cin>>keep>>a;
			for(int j=1;j<keep;j++){
			cin>>b;
			merge(a,b);
			}
		}
		root=find(0);
		cout<<num[root]<<endl;
	}
	return 0; 
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值