数据结构实验之二叉树四:(先序中序)还原二叉树

数据结构实验之二叉树四:(先序中序)还原二叉树

Time Limit: 1000MS Memory Limit: 65536KB
Problem Description

给定一棵二叉树的先序遍历序列和中序遍历序列,要求计算该二叉树的高度。

Input

输入数据有多组,每组数据第一行输入1个正整数N(1 <= N <= 50)为树中结点总数,随后2行先后给出先序和中序遍历序列,均是长度为N的不包含重复英文字母(区分大小写)的字符串。

 

Output

 输出一个整数,即该二叉树的高度。

Example Input
9 
ABDFGHIEC
FDHGIBEAC
Example Output
5
#include <stdio.h>
#include <string.h>
#include <stdlib.h>
struct bittree
{
    char data;
    struct bittree * l,* r;
};
struct bittree * create(int len,char * st1,char * st2)
{
    struct bittree * root;
    int i;
    if(len==0)
    {
        return NULL;
    }
    root=(struct bittree *)malloc(sizeof(struct bittree));
    root->data=st1[0];
    for(i=0;i<len;i++)
    {
        if(root->data==st2[i])
        {
            break;
        }
    }
    root->l=create(i,st1+1,st2);
    root->r=create(len-i-1,st1+i+1,st2+i+1);
    return root;

}
int houxu(struct bittree * p,int num)
{
    if(p!=NULL)
    {
        num++;
        if(houxu(p->l,num)>houxu(p->r,num))
        {
            return houxu(p->l,num);
        }
        else
        {
            return houxu(p->r,num);
        }

    }
    else
    {
        return num;
    }
}
int main()
{
    int len,num;
    char st1[99],st2[99];
    struct bittree * root;
    while(scanf("%d %s %s",&len,st1,st2)!=EOF)
    {
        root=create(len,st1,st2);
        num=0;
        num=houxu(root,num);
        printf("%d\n",num);
    }
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值