4/17 微小的贡献

把github上的项目下载到本地了,创了一个background branch。然而从rubymine里打开项目的时候发现好些个gem没装,ruby版本也不对。切换了ruby库,bundle install了一遍发现还是缺东西跑不起来,自己创建了一个能运行的rails项目后逐条检查了一下缺什么gem发现
gem 'tzinfo-data', platforms: [:mingw, :mswin, :x64_mingw, :jruby]

这行没有。

这个东西是一个管理时区(TimeZoneINFO)的包,其中的platforms参数是来描述运行环境的。一般来说在创建新项目的时候都会根据本地环境自动生成,这次是下载的在线项目,所以把自己的环境填上就好。

另外执行rails s的时候还报了不少错,万幸的是,rails很友好,会提醒“需要执行bin/...”命令,按照提示都执行一遍就可以正常运行了。

光配环境就花了整整一下午,希望明天可以顺利一点吧。

阅读更多

没有更多推荐了,返回首页