HDU 1005 Number Sequence

Problem Description
A number sequence is defined as follows:

f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.

Given A, B, and n, you are to calculate the value of f(n).
 

Input
The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.
 

Output
For each test case, print the value of f(n) on a single line.
 

Sample Input
  
  
1 1 3 1 2 10 0 0 0
 

Sample Output
  
  
2 5
思路:这道题刚开始用普通的方法,数组开了100000000会内存溢出,后来用两个变量循环使用解决这一问题,又超时了。显然,用普通的方法是行不通的。那么,我们在数学上遇到这种问题会想到找规律。对7取模,那么f(i)的值定在0-6之间, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7可以写成f(n) = (A * f(n - 1)mod 7 + B * f(n - 2)mod 7) mod 7,也就是说,无论a,b取多少,都可以转化成0-6之间的范围,得到的结果是一样 的。所以a,b的组合共有7*7 = 49种。也就是说,f(i)是一个周期函数,且周期定在49以内。我们只要求出0-49的值,求出周期,就可以了。
那么,周期如何求呢?注意到该函数,当前值与前两个值是相关的,若出现周期,定会从1,1,开始,而出现了1,1后面的值都能确定了。
结论:只要判断相邻两个数是1,1即可。最后还要注意的是,我们求出了cycle(周期),但是n% cycle会等于0,还需要我们把发f(0) 求出。
代码:
#include <iostream>
#include<cstdio>
#include<cstring>
using namespace std;

int lis[59];
int main()
{
    int a,b,n,i,cycle;
    while (scanf("%d %d %d",&a,&b,&n) && a && b && n)
    {
        memset(lis,0,sizeof(lis));
        lis[1] = 1;
        lis[2] = 1;
        if (n <= 2)
        {
            cout << 1 << endl;
        }
        else
        {
         for (i = 3; i <= 49; i++)
         {
            lis[i] = (a * lis[i-1] + b * lis[i-2]) % 7;
            if(lis[i] == 1 && lis[i-1] == 1)
            {
                break;
            }
         }
         if (i >= n)
         {
             cout << lis[n] << endl;
         }
         else
         {
            cycle = i-2;
            lis[0] = lis[cycle];
            cout << lis[n % cycle]<< endl;
         }
        }
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值