Spell checker

/*Spell checker
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 25450 Accepted: 9308
Description
You, as a member of a development team for a new spell checking program, are to write a module that will check the correctness of
given words using a known dictionary of all correct words in all their forms. If the word is absent in the dictionary then it can
be replaced by correct words (from the dictionary) that can be obtained by one of the following operations:
?deleting of one letter from the word;
?replacing of one letter in the word with an arbitrary letter;
?inserting of one arbitrary letter into the word.
Your task is to write the program that will find all possible replacements from the dictionary for every given word.
Input

The first part of the input file contains all words from the dictionary. Each word occupies its own line. This part is finished by
the single character ‘#’ on a separate line. All words are different. There will be at most 10000 words in the dictionary.
The next part of the file contains all words that are to be checked. Each word occupies its own line. This part is also finished
by the single character ‘#’ on a separate line. There will be at most 50 words that are to be checked.
All words in the input file (words from the dictionary and words to be checked) consist only of small alphabetic characters and
each one contains 15 characters at most.
Output
Write to the output file exactly one line for every checked word in the order of their appearance in the second part of the input file. If the word is correct (i.e. it exists in the dictionary) write the message: ” is correct”. If the word is not correct then write this word first, then write the character ‘:’ (colon), and after a single space write all its possible replacements, separated by spaces. The replacements should be written in the order of their appearance in the dictionary (in the first part of the input file). If there are no replacements for this word then the line feed should immediately follow the colon.
Sample Input
i
is
has
have
be
my
more
contest
me
too
if
award
#
me
aware
m
contest
hav
oo
or
i
fi
mre
#
Sample Output
me is correct
aware: award
m: i my me
contest is correct
hav: has have
oo: too
or:
i is correct
fi: i
mre: more me*/
题意:先给出一些字符串,作为字典,以‘#’结束;然后给出一系列的字符串,需要做的是比较这些字符串,以‘#’结束;如果这些字符串在字典中或少一个或多一个或者改动其中一个字符后的字符串在字典中就输出;

#include <stdio.h>
#include <string.h>
#include <string>
#include <iostream>
#include <stdlib.h>
using namespace std;
string str[10005],str1[10005];
int main()
{
    int dic=0,need=0;
    while(cin>>str[dic])
    {
        if(str[dic]=="#") 
            break;
        dic++;
    }
    while(cin>>str1[need])
    {
        if(str1[need]=="#") 
           break;
        need++;
    }
    for(int i=0;i<need;i++)
    { 
        int flog=0;    //标记,如果找得到相同的字符串,则continue。
        for(int j=0;j<dic;j++)
        {
            if(str1[i]==str[j]) 
            {
                cout<<str1[i]<<" is correct"<<endl;
                flog=1;
                break;
            }
        }
        if(flog==1) 
            continue;
        int len=str1[i].size();//类string的对象str1的长度 
        cout<<str1[i]<<":";
        for(int j=0;j<dic;j++)
        {
            int strl=str[j].size();
            if(strl==len||strl==len+1||strl==len-1)
            {  //字符串相差1的或者相等的,就用来匹配是否有可能相差一个字符,这是一种减枝的办法。
                int ans=0;
                if(len>strl)
                {   //那个较长的字符作为被匹配的,用短的来匹配长的字符串。
                    for(int m=0,d=0;m<len;m++)
                    {
                        if(str1[i][m]==str[j][d])
                        {
                            ans++;
                            d++;
                        }
                    }
                }
                else if(len<strl)
                {
                    for(int m=0,d=0;m<strl;m++)
                    {
                        if(str[j][m]==str1[i][d])
                        {
                            ans++;
                            d++;
                        }
                    }
                }
                else if(len==strl)
                {
                    for(int m=0,d=0;m<strl;m++,d++)
                        if(str[j][m]==str1[i][d]) 
                           ans++;
                }
                if(len>=strl&&ans==len-1)  
                    cout<<" "<<str[j];    
                if(len<strl&&ans==len)  
                   cout<<" "<<str[j];
            }
        }
        cout<<endl;
    }
    return 0;
} 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值