ICPC2017南宁邀请赛1001&&HDU6182(水

A Math Problem

You are given a positive integer n, please count how many positive integers k satisfy k^k≤n.

Description

You are given a positive integer n, please count how many positive integers k satisfy k^k≤n.

1≤n≤1018

Input

There are no more than 50 test cases.

Each case only contains a positivse integer n in a line.

Output

For each test case, output an integer indicates the number of positive integers k satisfy k^k≤n in a line.

Sample Input

1
4

Sample Output

1
2

题意

手写个pow函数 注意LL

AC代码

#include <bits/stdc++.h>
using namespace std;
#define LL long long
LL Pow(LL a, LL b)
{
    LL ans = 1;
    while(b) {
        if(b&1)
        ans = (ans * a);
        a = (a * a);
        b = b/2;
    }
    return ans;
}
int main()
{
    LL n;
    while(~scanf("%lld",&n)) {
        for(LL i = 15; i >= 0; i--) {
            if(Pow(i,i) <= n) {
                printf("%lld\n",i); break;
            }
        }
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值