题目链接:点击打开链接
Number Sequence
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 158103 Accepted Submission(s): 38720
Problem Description
A number sequence is defined as follows:
f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.
Given A, B, and n, you are to calculate the value of f(n).
f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.
Given A, B, and n, you are to calculate the value of f(n).
Input
The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.
Output
For each test case, print the value of f(n) on a single line.
Sample Input
1 1 3 1 2 10 0 0 0
Sample Output
2 5
思路:数比较大,感觉无从下手。就打个表看看有没有规律啊 我个zz
#include<cstdio>
#include<algorithm>
#include<cstring>
using namespace std;
int a,b,n;
int f[510];
int main()
{
while(~scanf("%d%d%d",&a,&b,&n)&&(a||b||n))
{
f[1]=1; f[2]=1;
int cnt;
bool flag=0;
for(int i=3;i<=500;i++)
{
f[i]=(a*f[i-1]+b*f[i-2])%7;
// printf("--%d--",f[i]); 打表先找周期
if(f[i]==1&&f[i-1]==1) // 找到周期
{
cnt=i;
break;
}
if(f[i]==0&&f[i-1]==0) // 发现第三项往后全部为 0
{
flag=1;
break;
}
}
if(flag)
{
puts(n>=3?"0":"1");
continue;
}
int t=cnt-2; // t 为周期
int ans=n%t;
printf("%d\n",f[ans?ans:t]);
}
return 0;
}