HDU 5327 Olympiad (2015 Multi-University Training Contest 4 2015多校联合)

水题。题目和HDU的另外一道题特别像,special number。只是special number不包含末尾是0的数字。在原来代码上稍作修改就可以了。

暴力打表就可以。因为数据量少。如果数据量大的话就需要用到二分了。

Olympiad

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 484    Accepted Submission(s): 349


Problem Description
You are one of the competitors of the Olympiad in numbers. The problem of this year relates to beatiful numbers. One integer is called beautiful if and only if all of its digitals are different (i.e. 12345 is beautiful, 11 is not beautiful and 100 is not beautiful). Every time you are asked to count how many beautiful numbers there are in the interval  [a,b] (ab) . Please be fast to get the gold medal!
 

Input
The first line of the input is a single integer  T (T1000) , indicating the number of testcases. 

For each test case, there are two numbers  a  and  b , as described in the statement. It is guaranteed that  1ab100000 .
 

Output
For each testcase, print one line indicating the answer. 
 

Sample Input
  
  
2 1 10 1 1000
 

Sample Output
  
  
10 738
 

Author
XJZX
 

Source

题目传送门:HDU5327 Olympiad

代码如下:

#include <cstdio>
#include <cstring>
#include <cstdlib>
#include <iostream>
#include <algorithm>
using namespace std;
#define N 100010
int num,q[N];
int is_number(int x)
{
    int a[11],tmp;
     memset(a,0,sizeof(a));
     while(x>0)
     {
         tmp=x%10;
         a[tmp]++;
         if(a[tmp]>=2)
            return 0;
         x/=10;
     }
     return 1;
}
int tot=0;
void Init()
{
    int i;
    int num=0;
    for(i=1;i<=100010;i++)
    {
        if(is_number(i)==1)
        {
            q[++tot]=++num;
        }
        else
        {
            q[++tot]=q[tot-1];
        }
    }
}
int main()
{
    int t,a,b,i,j;
    Init();
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d",&a,&b);
            cout<<q[b]-q[a-1]<<endl;
    }
    return 0;
}

今天试了一下用set来做。注意要用C++。用G++会超时的。G++1000ms超时。C++93ms过了。

代码:

#include <cstdio>
#include <iostream>
#include <algorithm>
#include <cmath>
#include <cstdlib>
#include <set>
#define N 100005
int a[N];
using namespace std;
void init()
{
	int i,sum,count=0,k=0,t;
	set<int> s;
	for(i=1;i<=N;i++)
	{
		sum=0;
		t=i;
		s.clear();
		while(t)
		{
			s.insert(t%10);
			t=t/10;
			sum++;
		}
		if(sum==s.size())
			a[++k]=++count;
		else
			a[++k]=a[k-1];
	}
}
int main()
{
	int T,x,y;
	init();
	scanf("%d",&T);
	while(T--)
	{
		scanf("%d%d",&x,&y);
		printf("%d\n",a[y]-a[x-1]);
	}
	return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值