Game with Pearls

Tom and Jerry are playing a game with tubes and pearls. The rule of the game is:

1) Tom and Jerry come up together with a number K.

2) Tom provides N tubes. Within each tube, there are several pearls. The number of pearls in each tube is at least 1 and at most N.

3) Jerry puts some more pearls into each tube. The number of pearls put into each tube has to be either 0 or a positive multiple of K. After that Jerry organizes these tubes in the order that the first tube has exact one pearl, the 2nd tube has exact 2 pearls, …, the Nth tube has exact N pearls.

4) If Jerry succeeds, he wins the game, otherwise Tom wins.

Write a program to determine who wins the game according to a given N, K and initial number of pearls in each tube. If Tom wins the game, output “Tom”, otherwise, output “Jerry”. Input
The first line contains an integer M (M<=500), then M games follow. For each game, the first line contains 2 integers, N and K (1 <= N <= 100, 1 <= K <= N), and the second line contains N integers presenting the number of pearls in each tube.
Output
For each game, output a line containing either “Tom” or “Jerry”.
Sample Input
2 
5 1 
1 2 3 4 5 
6 2 
1 2 3 4 5 5 
Sample Output
Jerry 
Tom 

题意:Jerry 和 Tom 玩一个游戏 , 给你 n 个盒子 , a[ i ] 表示开始时 ,第 i 个盒子中的小球的个数 。 然后 Jerry 可以在每个

盒子里加入 0 或 k的倍数的小球 , 操作完后,Jerry 可以重新排列 盒子的顺序,最终使 第 i 个盒子中有 i 个小球。 若Jerry能

使最终的盒子变成那样,就输出 “Jerry” ,否则 输出 “Tom” 。

#include<stdio.h>
#include<algorithm>
#include<string.h>
using namespace std;
int a[1000],b[1000];
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        int n,m;
        memset(b,0,sizeof(b));
        scanf("%d%d",&n,&m);
        for(int i=1;i<=n;i++)
        {
            scanf("%d",&a[i]);
        }
        int sum;
        int sum1;
        int p=0;
        for(int i=1;i<=n;i++)
        {
            sum1=0;
            sum=0;
            for(int j=1;j<=n;j++)
            {
                if((i-a[j])%m==0&&(i-a[j])>=0&&a[j]!=-1&&sum==0)
                {
                    sum=1;
                    a[j]=-1;
                }
            }
            if(sum==1)
            {
                continue;
            }
            else
            {
                p=1;
            }
        }
        if(p==0)
        {
            printf("Jerry\n");
        }
        else
        {
            printf("Tom\n");
        }
    }
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值