1410242114-hd-Balloon Comes!

Balloon Comes!

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 20169    Accepted Submission(s): 7597


Problem Description
The contest starts now! How excited it is to see balloons floating around. You, one of the best programmers in HDU, can get a very beautiful balloon if only you have solved the very very very... easy problem.
Give you an operator (+,-,*, / --denoting addition, subtraction, multiplication, division respectively) and two positive integers, your task is to output the result.
Is it very easy?
Come on, guy! PLMM will send you a beautiful Balloon right now!
Good Luck!

Input
Input contains multiple test cases. The first line of the input is a single integer T (0<T<1000) which is the number of test cases. T test cases follow. Each test case contains a char C (+,-,*, /) and two integers A and B(0<A,B<10000).Of course, we all know that A and B are operands and C is an operator.

Output
For each case, print the operation result. The result should be rounded to 2 decimal places If and only if it is not an integer.

Sample Input
  
  
4 + 1 2 - 1 2 * 1 2 / 1 2

Sample Output
  
  
3 -1 2 0.50
题目大意
       给定一个符号和两个整数,根据符号对这两个数进行运算,如果存在小数的话就保留两位小数
代码
#include<stdio.h>
int main()
{
	int t;
	int a,b;
	char c;
	int i,j;
	scanf("%d",&t);
	getchar();
	while(t--)
	{
		scanf("%c%d%d",&c,&a,&b);
		getchar();
		switch(c)
		{
			case'+':printf("%d\n",a+b);break;
		    case'-':printf("%d\n",a-b);break;
		    case'*':printf("%d\n",a*b);break;
		    case'/':{//如果得到的不是整数的话就需要保留2位小数。 
				         if(a%b==0)
			                 printf("%d\n",a/b);
						 else
						     printf("%.2lf\n",a/(b*1.0));
					 }break;
		}
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
你帮我检查下我的代码吧! plugin.xml内容如下: ``` <idea-plugin> <id>com.your.company.unique.plugin.id</id> <name>wkx_plugin</name> <version>1.0</version> <vendor email="wangkexin6@yourcompany.com" url="http://www.hikvision.com">HikVision</vendor> <!-- description><![CDATA[ xml和excel互相转换插件.<br> www.wkx666.com</description --> <!-- change-notes><![CDATA[ Add change notes here.<br> most HTML tags may be used ]]> </change-notes--> <!-- please see https://www.jetbrains.org/intellij/sdk/docs/basics/getting_started/build_number_ranges.html for description --> <idea-version since-build="173.0"/> <!-- please see https://www.jetbrains.org/intellij/sdk/docs/basics/getting_started/plugin_compatibility.html on how to target different products --> <depends>com.intellij.modules.platform</depends> <extensions defaultExtensionNs="com.intellij"> <!-- Add your extensions here --> <actions> <action id="myAction" class="com.example.HelloWorldAction" text="My Action" description="My description"> <add-to-group group-id="MainMenu.Tools" anchor="last"/> <keyboard-shortcut first-keystroke="control alt A"/> </action> </actions> </extensions> <actions> <!-- Add your actions here --> </actions> </idea-plugin> ``` HelloWorldAction.kt内容如下: ``` import com.intellij.notification.NotificationDisplayType import com.intellij.notification.NotificationGroup import com.intellij.notification.NotificationType import com.intellij.openapi.actionSystem.AnAction import com.intellij.openapi.actionSystem.AnActionEvent class HelloWorldAction : AnAction() { override fun actionPerformed(event: AnActionEvent) { //这里创建了一个消息提示弹窗,在IDE中展示“Hello World” val notificationGroup = NotificationGroup( "myActionId", NotificationDisplayType.BALLOON, true ) val notification = notificationGroup.createNotification( "chentao Demo", "Hello World", "", NotificationType.INFORMATION ).notify(event.project) //从方法的Event对象中获取到当前IDE正在展示的project,在该project中展示弹窗 } } ```
最新发布
07-25

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值