1412111358-hd-Text Reverse

Text Reverse

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 17738    Accepted Submission(s): 6729


Problem Description
Ignatius likes to write words in reverse way. Given a single line of text which is written by Ignatius, you should reverse all the words and then output them.
 

Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains a single line with several words. There will be at most 1000 characters in a line.
 

Output
For each test case, you should output the text which is processed.
 

Sample Input
  
  
3 olleh !dlrow m'I morf .udh I ekil .mca
 

Sample Output
  
  
hello world! I'm from hdu. I like acm.
Hint
Remember to use getchar() to read '\n' after the interger T, then you may use gets() to read a line and process it.
 题目大意
        给多组英文句子,然后将句子中的每个单词的字母逆序输出
解题思路
        存入数组一次判断,遇到空格则将子连逆序输出并清空子连,否则将其存入子连。
代码
#include<stdio.h>
#include<string.h>
char a[1100],b[1100];
int main()
{
	int n;
	int len,nowl;
	int i,j,k,l;
	scanf("%d",&n);
	getchar();
	while(n--)
	{
		gets(a);
		len=strlen(a);
		for(nowl=0,i=0;i<len;i++)
		{
			if(a[i]!=' ')
			{
				b[nowl]=a[i];
				nowl++;
			}
			else
			{
				for(j=nowl-1;j>=0;j--)
				    printf("%c",b[j]);
				printf(" ");
				nowl=0;
			}
		}
		//因为上面的循环是到len即截至,所以还会有一个子连存在数组b中但是并没有输出 
		for(j=nowl-1;j>=0;j--)
		    printf("%c",b[j]);
		printf("\n");
	}
	return 0;
} 


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值