OJ Problem 3482 采用递归求第n位数(c#)

题目描述

一数列的规则如下:1、1、2、3、5、8、13、21、34......。求第n位数是多少?

输入

输入一个正整数,代表求第几位数字

输出

输出第n位数字

样例输入

30

样例输出

832040

提示

输入数字必须大于零

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.Threading.Tasks;
 
namespace ConsoleApplication1
{
    class Program
    {
        static void Main(string[] args)
        {
            int n = int.Parse(Console.ReadLine());
            int x = 1;
            int y = 1;
            int z;
            for (int i = 3; i <= n;i++)
            {
                z=x+y;
                x=y;
                y=z;
            }
            Console.WriteLine(y);
        }
    }
}

 

  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值