POJ - 2376 Cleaning Shifts——贪心

题目:Cleaning Shifts

Farmer John is assigning some of his N (1 <= N <= 25,000) cows to do some cleaning chores around the barn. He always wants to have one cow working on cleaning things up and has divided the day into T shifts (1 <= T <= 1,000,000), the first being shift 1 and the last being shift T.

Each cow is only available at some interval of times during the day for work on cleaning. Any cow that is selected for cleaning duty will work for the entirety of her interval.

Your job is to help Farmer John assign some cows to shifts so that (i) every shift has at least one cow assigned to it, and (ii) as few cows as possible are involved in cleaning. If it is not possible to assign a cow to each shift, print -1.
Input

  • Line 1: Two space-separated integers: N and T

  • Lines 2…N+1: Each line contains the start and end times of the interval during which a cow can work. A cow starts work at the start time and finishes after the end time.

Output

  • Line 1: The minimum number of cows Farmer John needs to hire or -1 if it is not possible to assign a cow to each shift.

Sample Input

3 10
1 7
3 6
6 10

Sample Output

2

Hint
This problem has huge input data,use scanf() instead of cin to read data to avoid time limit exceed.

INPUT DETAILS:

There are 3 cows and 10 shifts. Cow #1 can work shifts 1…7, cow #2 can work shifts 3…6, and cow #3 can work shifts 6…10.

OUTPUT DETAILS:

By selecting cows #1 and #3, all shifts are covered. There is no way to cover all the shifts using fewer than 2 cows.

题意:

农夫约翰有很多牛,他想让这些牛来给他的牲口棚周围做清洁工作,并将一天分为T班(1<=T<=1000000),第一班是1班,最后一班是T班。现在每头牛都只能在白天的某些时间间隔内进行清洁工作,你的工作是帮助农夫约翰分配一些奶牛轮班,以便每个轮班至少分配一头奶牛,以及让参与清洁的奶牛最少。如果无法为每个班次分配一头奶牛,请输出-1。

思路:

先以开始工作的时间从小到大排序。排完序后可分为三类情况:(1)第一头牛最早的开始时间是1且结束时间大于或等于n,那么只需要1头牛就够了,(2)如果第一头牛的开始时间不是1,那一定不符合条件,输出-1,(想想为什么?)(3)既不是(1)也不是(2)的话,就需要贪心找出最优解了,找不到当然就要输出-1喽,提醒一下,区间可以是断的,比如[1,3] [4,7] 只要后一个start<=前一个end+1就行

AC 代码

#include<stdio.h>
#include<algorithm>
using namespace std;
struct dd
{
    int x,y;
}a[25000];
bool cmp(dd tx,dd ty)
{
    if(tx.x==ty.x)
        return tx.y<ty.y;
    return tx.x<ty.x;
}
int main()
{
    int n,m,t,i;
    scanf("%d%d",&t,&n);
    for(i=0;i<t;i++)
        scanf("%d%d",&a[i].x,&a[i].y);
    sort(a,a+t,cmp);
    if(a[0].x==1&&a[0].y>=n)
        printf("1\n");
    else if(a[0].x!=1)
        printf("-1\n");
    else
    {
        m=a[0].y;
        int sum=1;
        for(int i=1;i<t&&m<n;)
        {
            sum++;
            int mm=m;
            if(a[i].x>m+1)
            {
                printf("-1\n");
                return 0;
            }
            while(i<t&&a[i].x<=m+1)
            {
                mm=max(mm,a[i].y);
                i++;
            }
            m=mm;
            if(m>=n)
                break;
        }
        if(m<n)
            printf("-1\n");
        else
            printf("%d\n",sum);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值