公主被恶人抓走,被关押在牢房的某个地方。牢房用N*M (N, M <= 200)的矩阵来表示。矩阵中的每项可以代表道路(@)、墙壁(#)、和守卫(x)。
英勇的骑士(r)决定孤身一人去拯救公主(a)。我们假设拯救成功的表示是“骑士到达了公主所在的位置”。由于在通往公主所在位置的道路中可能遇到守卫,骑士一旦遇到守卫,必须杀死守卫才能继续前进。
现假设骑士可以向上、下、左、右四个方向移动,每移动一个位置需要1个单位时间,杀死一个守卫需要花费额外的1个单位时间。同时假设骑士足够强壮,有能力杀死所有的守卫。
给定牢房矩阵,公主、骑士和守卫在矩阵中的位置,请你计算拯救行动成功需要花费最短时间。
Input
第一行为一个整数S,表示输入的数据的组数(多组输入)
随后有S组数据,每组数据按如下格式输入
1、两个整数代表N和M, (N, M <= 200).
2、随后N行,每行有M个字符。"@"代表道路,"a"代表公主,"r"代表骑士,"x"代表守卫, "#“代表墙壁。
Output
如果拯救行动成功,输出一个整数,表示行动的最短时间。
如果不可能成功,输出"Impossible”
Sample Input
2
7 8
#@#####@
#@a#@@r@
#@@#x@@@
@@#@@#@#
#@@@##@@
@#@@@@@@
@@@@@@@@
13 40
@x@@##x@#x@x#xxxx##@#x@x@@#x#@#x#@@x@#@x
xx###x@x#@@##xx@@@#@x@@#x@xxx@@#x@#x@@x@
#@x#@x#x#@@##@@x#@xx#xxx@@x##@@@#@x@@x@x
@##x@@@x#xx#@@#xxxx#@@x@x@#@x@@@x@#@#x@#
@#xxxxx##@@x##x@xxx@@#x@x####@@@x#x##@#@
#xxx#@#x##xxxx@@#xx@@@x@xxx#@#xxx@x#####
#x@xxxx#@x@@@@##@x#xx#xxx@#xx#@#####x#@x
xx##@#@x##x##x#@x#@a#xx@##@#@##xx@#@@x@x
x#x#@x@#x#@##@xrx@x#xxxx@##x##xx#@#x@xx@
#x@@#@###x##x@x#@@#@@x@x@@xx@@@@##@@x@@x
x#xx@x###@xxx#@#x#@@###@#@##@x#@x@#@@#@@
#@#x@x#x#x###@x@@xxx####x@x##@x####xx#@x
#x#@x#x######@@#x@#xxxx#xx@@@#xx#x#####@
Sample Output
13
7
超时的BFS代码:
#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
#include<queue>
using namespace std;
int dir[4][2]= {1,0,-1,0,0,1,0,-1};
char map[205][205];
int n,m;
int vis[205][205];
struct node {
int x,y,sec;
friend bool operator < (node a,node b) {
return a.sec>b.sec;
}
};
void bfs(node st) {
priority_queue<node> Q;
Q.push(st);
memset(vis,0,sizeof(vis));
int ans;
node a,b;
while(!Q.empty()) {
a=Q.top();
Q.pop();
vis[a.x][a.y]=1;
if(map[a.x][a.y]=='a') {
cout<<a.sec<<endl;
return;
}
for(int i=0; i<4; i++) {
b.x=a.x+dir[i][0];
b.y=a.y+dir[i][1];
b.sec=a.sec+1;
if(b.x>0&&b.x<=n&&b.y>0&&b.y<=m&&!vis[b.x][b.y]&&map[b.x][b.y]!='#') {
if(map[b.x][b.y]=='x') {
b.sec++;
}
Q.push(b);
}
}
}
cout<<"Impossible"<<endl;
}
int main() {
int S;
cin>>S;
while(S--) {
cin>>n>>m;
node st;
for(int i=1; i<=n; i++) {
for(int j=1; j<=m; j++) {
cin>>map[i][j];
if(map[i][j]=='r') {
st.x=i;
st.y=j;
st.sec=0;
}
}
}
bfs(st);
}
return 0;
}
push之前就修改vis数组:AC
275ms
#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
#include<queue>
using namespace std;
int dir[4][2]= {1,0,-1,0,0,1,0,-1};
char map[205][205];
int n,m;
int vis[205][205];
struct node {
int x,y,sec;
friend bool operator < (node a,node b) {
return a.sec>b.sec;
}
};
void bfs(node st) {
priority_queue<node> Q;
Q.push(st);
memset(vis,0,sizeof(vis));
int ans;
node a,b;
vis[st.x][st.y]=1;
while(!Q.empty()) {
a=Q.top();
Q.pop();
if(map[a.x][a.y]=='a') {
cout<<a.sec<<endl;
return;
}
for(int i=0; i<4; i++) {
b.x=a.x+dir[i][0];
b.y=a.y+dir[i][1];
b.sec=a.sec+1;
if(b.x>0&&b.x<=n&&b.y>0&&b.y<=m&&!vis[b.x][b.y]&&map[b.x][b.y]!='#') {
if(map[b.x][b.y]=='x') {
b.sec++;
}
vis[b.x][b.y]=1;
Q.push(b);
}
}
}
cout<<"Impossible"<<endl;
}
int main() {
int S;
cin>>S;
while(S--) {
cin>>n>>m;
node st;
for(int i=1; i<=n; i++) {
for(int j=1; j<=m; j++) {
cin>>map[i][j];
if(map[i][j]=='r') {
st.x=i;
st.y=j;
st.sec=0;
}
}
}
bfs(st);
}
return 0;
}