hdu 6029 Graph Theory 【直接连线】

hdu 6029 Graph Theory 【直接连线】


对于输入的a等于1  如果前面有空闲的点 

直接匹配 否则自己变成空闲的点

a=2 的时候  空闲的点加一 

直到最后 如果没有空余的点 输出yes


Graph Theory


Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 145    Accepted Submission(s): 76




Problem Description
Little Q loves playing with different kinds of graphs very much. One day he thought about an interesting category of graphs called ``Cool Graph'', which are generated in the following way:
Let the set of vertices be {1, 2, 3, ..., n}. You have to consider every vertice from left to right (i.e. from vertice 2 to n). At vertice i, you must make one of the following two decisions:
(1) Add edges between this vertex and all the previous vertices (i.e. from vertex 1 to i−1).
(2) Not add any edge between this vertex and any of the previous vertices.
In the mathematical discipline of graph theory, a matching in a graph is a set of edges without common vertices. A perfect matching is a matching that each vertice is covered by an edge in the set.
Now Little Q is interested in checking whether a ''Cool Graph'' has perfect matching. Please write a program to help him.
 


Input
The first line of the input contains an integer T(1≤T≤50), denoting the number of test cases.
In each test case, there is an integer n(2≤n≤100000) in the first line, denoting the number of vertices of the graph.
The following line contains n−1 integers a2,a3,...,an(1≤ai≤2), denoting the decision on each vertice.
 


Output
For each test case, output a string in the first line. If the graph has perfect matching, output ''Yes'', otherwise output ''No''.
 


Sample Input
3
2
1
2
2
4
1 1 2
 


Sample Output
Yes
No
No


#include <stdio.h>
#include <bits/stdc++.h>
#define mod 1000000007
#define read(); freopen("input.txt","r",stdin);
typedef long long ll;
using namespace std;
int t,n;
int main()
{
	cin>>t;
	while(t--){
		cin>>n;
		int a;
		int sum=1;
		for(int i=1;i<n;i++){
			scanf("%d",&a);
			if(a==1){
				if(sum>=1)sum--;
				else sum++;
			}else{
				sum++;
			}
		}
		if(sum==0)printf("Yes\n");
		else printf("No\n");
		
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值