poj 2081 Recaman's Sequence (dp)

Recaman's Sequence
Time Limit: 3000MS Memory Limit: 60000K
Total Submissions: 22566 Accepted: 9697

Description

The Recaman's sequence is defined by a0 = 0 ; for m > 0, a m = a m−1 − m if the rsulting a m is positive and not already in the sequence, otherwise a m = a m−1 + m. 
The first few numbers in the Recaman's Sequence is 0, 1, 3, 6, 2, 7, 13, 20, 12, 21, 11, 22, 10, 23, 9 ... 
Given k, your task is to calculate a k.

Input

The input consists of several test cases. Each line of the input contains an integer k where 0 <= k <= 500000. 
The last line contains an integer −1, which should not be processed.

Output

For each k given in the input, print one line containing a k to the output.

Sample Input

7
10000
-1

Sample Output

20
18658

 

Java AC 代码

import java.util.Scanner;

public class Main {

    public static void main(String[] args) {
        
        Scanner sc = new Scanner(System.in);
        int n = 0;
        int[] result;
        boolean[] marked = new boolean[10000000];
        while((n = sc.nextInt()) != -1) {
            result = new int[n + 1];
            for(int i = 1; i < n + 1; i++) {
                int a = result[i - 1] - i;
                if(a > 0 && !marked[a]) {
                    result[i] = a;
                    marked[a] = true;
                }
                else {
                    result[i] = a + 2 * i;
                    marked[a + 2 * i] = true;
                }
            }
            System.out.println(result[n]);
            for(int i = 0; i < 10000000; i++ )
                marked[i] = false;
         }
    }
}

 

转载于:https://www.cnblogs.com/kkkkkk/p/5547104.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值