多校Key Set (快速幂)

Key Set
Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 476    Accepted Submission(s): 251
Problem Description

soda has a set S with n integers {1,2,…,n}. A set is called key set if the sum of integers in the set is an even number. He wants to know how many nonempty subsets of S are key set.

 
Input

There are multiple test cases. The first line of input contains an integer T (1≤T≤105), indicating the number of test cases. For each test case:
The first line contains an integer n (1≤n≤109), the number of integers in the set.

 
Output

For each test case, output the number of key sets modulo 1000000007.

 
Sample Input

4 1 2 3 4

 
Sample Output

0 1 3 7
 #include <iostream>
#include <cstdio>
#include <cstring>
#include <cstdlib>
#include <algorithm>
using namespace std;
#define mod 1000000007
long long ksm(int t,int n)
{
    long long s=1;
    while(n>0)
    {
        if(n&2!=0)
        {
            n=n-1;
            s=s*t%mod;
        }
        t=t*t%mod;
        n=n/2;
    }
    return s;
}
int main()
{
    int t;
    int n;
    cin>>t;
    while(t--)
    {
        cin>>n;
       cout<<ksm(2,n-1)-1<<endl;
    }
}

 

转载于:https://www.cnblogs.com/dshn/p/4750527.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值