hdoj--5567--sequence1(水题)

sequence1

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 345    Accepted Submission(s): 254



Problem Description
Given an array a with length n, could you tell me how many pairs (i,j) ( i < j ) for abs(aiaj) mod b=c.
 

Input
Several test cases(about 5)

For each cases, first come 3 integers, n,b,c(1n100,0c<b109)

Then follows n integers ai(0ai109)
 

Output
For each cases, please output an integer in a line as the answer.
 

Sample Input
 
  
3 3 2 1 2 3 3 3 1 1 2 3
 

Sample Output
 
  
1 2
 

Source
 

Recommend
hujie   |   We have carefully selected several similar problems for you:   5589  5588  5587  5586  5585


#include<stdio.h>
#include<string.h>
#include<math.h>
int n,b,c;
long long a[1010];
bool judge(long long x,long long y)
{
	if(abs(x-y)%b==c)
	return true;
	return false; 
}
int main()
{
	while(scanf("%d%d%d",&n,&b,&c)!=EOF)
	{
		memset(a,0,sizeof(a));
		for(int i=0;i<n;i++)
		scanf("%lld",&a[i]);
		int sum=0;
		for(int i=0;i<n;i++)
		{
			for(int j=i+1;j<n;j++)
			{
				if(judge(a[i],a[j]))
				sum++;
			}
		}
		printf("%d\n",sum);
	}
	return 0;
} 


转载于:https://www.cnblogs.com/playboy307/p/5273659.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值