POJ2828 Buy Tickets

原题链接:http://poj.org/problem?id=2828

Buy Tickets

Description

Railway tickets were difficult to buy around the Lunar New Year in China, so we must get up early and join a long queue…

The Lunar New Year was approaching, but unluckily the Little Cat still had schedules going here and there. Now, he had to travel by train to Mianyang, Sichuan Province for the winter camp selection of the national team of Olympiad in Informatics.

It was one o’clock a.m. and dark outside. Chill wind from the northwest did not scare off the people in the queue. The cold night gave the Little Cat a shiver. Why not find a problem to think about? That was none the less better than freezing to death!

People kept jumping the queue. Since it was too dark around, such moves would not be discovered even by the people adjacent to the queue-jumpers. “If every person in the queue is assigned an integral value and all the information about those who have jumped the queue and where they stand after queue-jumping is given, can I find out the final order of people in the queue?” Thought the Little Cat.

Input

There will be several test cases in the input. Each test case consists of N + 1 lines where N (1 ≤ N ≤ 200,000) is given in the first line of the test case. The next N lines contain the pairs of values Posi and Vali in the increasing order of i (1 ≤ i ≤ N). For each i, the ranges and meanings of Posi and Vali are as follows:

Posi ∈ [0, i − 1] — The i-th person came to the queue and stood right behind the Posi-th person in the queue. The booking office was considered the 0th person and the person at the front of the queue was considered the first person in the queue.
Vali ∈ [0, 32767] — The i-th person was assigned the value Vali.
There no blank lines between test cases. Proceed to the end of input.

Output

For each test cases, output a single line of space-separated integers which are the values of people in the order they stand in the queue.

Sample Input

4
0 77
1 51
1 33
2 69
4
0 20523
1 19243
1 3890
0 31492

Sample Output

77 33 69 51
31492 20523 3890 19243

Hint

The figure below shows how the Little Cat found out the final order of people in the queue described in the first test case of the sample input.

题目大意

排队买票是一件令人很焦躁的亊情。售票窗口前排了一列长队,而且不断有人往前插队。由于天太黑了,人们并不知道有人插队。但是每个人身上有一个标记(不同的人的标记可能相同)Val,并且知道第i个人来了队伍之后会走到第 Posi P o s i 个人的后面。售票窗口记为第0个人,所以走到第0个人的后面意味着插到队伍首端了。
现在,给出以上信息,你能求出最后的Val的序列吗?

题解

平衡树裸题因为总人数不变,所以我们考虑线段树。。。

因为是线段树,所以当然不能有什么平移之类操作,于是考虑离线倒着插入,直接插入到最终位置。

因为要直接插入到最终位置,需要倒推前面的序列,所以需要线段树维护当前区间剩余空间数,最底层记录val,剩下就是基本的单点修改+查询了。

代码
#include<cstdio>
#include<cstring>
using namespace std;
const int M=200005;
struct node{
    int vac,val,le,ri;
    node()
    {memset(this,0,sizeof(this));}
};
node tree[M<<2];
int n,data[M][2];
void up(int v)
{
    tree[v].vac=tree[v<<1].vac+tree[v<<1|1].vac;
}
void build(int v,int le,int ri)
{
    tree[v].le=le;
    tree[v].ri=ri;
    if(le==ri)
    {
        tree[v].vac=1;
        return;
    }
    int mid=(le+ri)>>1;
    build(v<<1,le,mid);
    build(v<<1|1,mid+1,ri);
    up(v);
}
void ins(int v,int pos,int val)
{
    if(tree[v].le==tree[v].ri)
    {
        tree[v].val=val;
        tree[v].vac=0;
        return;
    }
    if(pos<=tree[v<<1].vac)
    ins(v<<1,pos,val);
    else
    ins(v<<1|1,pos-tree[v<<1].vac,val);
    up(v);
}
int que(int v,int pos)
{
    if(tree[v].le==tree[v].ri)return tree[v].val;
    int mid=(tree[v].le+tree[v].ri)>>1;
    if(pos<=mid)que(v<<1,pos);
    else que(v<<1|1,pos);
}
void in()
{
    for(int i=1;i<=n;++i)
    scanf("%d%d",&data[i][0],&data[i][1]);
}
void ac()
{
    build(1,1,n);
    for(int i=n;i>=1;--i)
    ins(1,data[i][0]+1,data[i][1]);
    for(int i=1;i<=n;++i)
    printf("%d ",que(1,i));
    putchar(10);
}
int main()
{
    while(scanf("%d",&n)!=EOF)
    in(),ac();
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

ShadyPi

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值