HDU 2594 Simpsons’ Hidden Talents(KMP的Next数组应用)

 

Simpsons’ Hidden Talents

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 6888    Accepted Submission(s): 2461

Problem Description
Homer: Marge, I just figured out a way to discover some of the talents we weren’t aware we had.
Marge: Yeah, what is it?
Homer: Take me for example. I want to find out if I have a talent in politics, OK?
Marge: OK.
Homer: So I take some politician’s name, say Clinton, and try to find the length of the longest prefix
in Clinton’s name that is a suffix in my name. That’s how close I am to being a politician like Clinton
Marge: Why on earth choose the longest prefix that is a suffix???
Homer: Well, our talents are deeply hidden within ourselves, Marge.
Marge: So how close are you?
Homer: 0!
Marge: I’m not surprised.
Homer: But you know, you must have some real math talent hidden deep in you.
Marge: How come?
Homer: Riemann and Marjorie gives 3!!!
Marge: Who the heck is Riemann?
Homer: Never mind.
Write a program that, when given strings s1 and s2, finds the longest prefix of s1 that is a suffix of s2.
 

 

Input
Input consists of two lines. The first line contains s1 and the second line contains s2. You may assume all letters are in lowercase.
 

 

Output
Output consists of a single line that contains the longest string that is a prefix of s1 and a suffix of s2, followed by the length of that prefix. If the longest such string is the empty string, then the output should be 0.
The lengths of s1 and s2 will be at most 50000.
 

 

Sample Input
clinton homer riemann marjorie
 

 

Sample Output
0 rie 3
 

 

Source
 

 


题目链接:HDU 2594

以前学KMP的时候看到这题,但是题解都看不懂= =因为当时一点不懂next数组的意义,更不用提应用了……

直到想起之前的暑假练习题,发现next数组next[i]的值就是一个字符串中以i所在位置为结尾(超尾)的最长公共前缀与后缀长度,题目求的就是最长公共前后缀,那肯定要把两个字符串拼到一起,后面的串接到前面串上,然后这题还有一个坑点,若两个串非常相似比如333 33333,那这样要考虑另外的情况:公共前后缀长度是否超出任意串的长度,由于next值从len-1开始是一个递减的数列,那可以一直往前迭代就可以找到第一个小于等于min(la,lb)的长度了,具体看代码

代码:

#include<iostream>
#include<algorithm>
#include<cstdlib>
#include<sstream>
#include<cstring>
#include<cstdio>
#include<string>
#include<deque>
#include<stack>
#include<cmath>
#include<queue>
#include<set>
#include<map>
using namespace std;
#define INF 0x3f3f3f3f
#define CLR(x,y) memset(x,y,sizeof(x))
#define LC(x) (x<<1)
#define RC(x) ((x<<1)+1)
#define MID(x,y) ((x+y)>>1)
typedef pair<int,int> pii;
typedef long long LL;
const double PI=acos(-1.0);
const int N=50010;
char s1[N<<1],s2[N];
int nxt[N<<1];
void getnext()
{
    CLR(nxt,0);
    strcat(s1,s2);
    int j=0,k=nxt[0]=-1;
    int len=strlen(s1);
    while (j<len)
    {
        if(k==-1||s1[j]==s1[k])
            nxt[++j]=++k;
        else
            k=nxt[k];
    }
}
int main(void)
{
    int i,j,index;
    while (~scanf("%s%s",s1,s2))
    {
        int la=strlen(s1);
        int lb=strlen(s2);
        getnext();
        int L=la+lb;
        index=nxt[L];//这里是总长度而不是l-1 
        if(!index)
            puts("0");
        else
        {
            int minlen=min<int>(la,lb);
            while (index>minlen)//若超出长度 
                index=nxt[index];//向前迭代寻找 
            for (i=0; i<index; ++i)
                putchar(s1[i]);
            putchar(' ');
            printf("%d\n",index);
        }
    }
    return 0;
}

转载于:https://www.cnblogs.com/Blackops/p/5766265.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值