The following packages have unmet dependencies错误

当出现类似这类错误:

The following packages have unmet dependencies:
 python-dev : Depends: python (= 2.7.5-5ubuntu3) but 2.7.12-1~16.04 is to be installed
              Depends: libpython-dev (= 2.7.5-5ubuntu3) but it is not going to be installed
              Depends: python2.7-dev (>= 2.7.5-1~) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

这是由于安装包的版本太新,其依赖包和旧版本冲突导致。

网上常见解决方法:apt-get -f install,but it doesn't work for me,或者说使用aptitude的,试了下很慢。

 

后来我把阿里源换回Ubuntu原生的源就可以安装了,因为阿里源的包太新。

转载于:https://www.cnblogs.com/willaty/p/9522591.html

已标记关键词 清除标记
表情包
插入表情
评论将由博主筛选后显示,对所有人可见 | 还能输入1000个字符
相关推荐
©️2020 CSDN 皮肤主题: 大白 设计师:CSDN官方博客 返回首页