Children’s Queue
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 160 Accepted Submission(s): 102
Problem Description
There are many students in PHT School. One day, the headmaster whose name is PigHeader wanted all students stand in a line. He prescribed that girl can not be in single. In other words, either no girl in the queue or more than one girl stands side by side. The case n=4 (n is the number of children) is like
FFFF, FFFM, MFFF, FFMM, MFFM, MMFF, MMMM
Here F stands for a girl and M stands for a boy. The total number of queue satisfied the headmaster’s needs is 7. Can you make a program to find the total number of queue with n children?
FFFF, FFFM, MFFF, FFMM, MFFM, MMFF, MMMM
Here F stands for a girl and M stands for a boy. The total number of queue satisfied the headmaster’s needs is 7. Can you make a program to find the total number of queue with n children?
Input
There are multiple cases in this problem and ended by the EOF. In each case, there is only one integer n means the number of children (1<=n<=1000)
Output
For each test case, there is only one integer means the number of queue satisfied the headmaster’s needs.
Sample Input
1
2
3
Sample Output
1
2
4
注意:
1、递归公式
1)m
2)mff
3)mfff
a:安全序列后加ff或者m,结果仍然安全。
b:不安全序列后加ff可使其安全,虽然mf加f也能得到安全序列,但与a情况重复。
故:公式a[n]=a[n-1]+a[n-2]+a[n-4];
2、大数,高精度问题。可以用二维数组模拟大数计算。n=1000时输出结果:
12748494904808148294446671041721884239818005733501580815621713101333980596197474
74433619974245291299822523591089179822154130383839594330018972951428262366519975
47955743099808702532134666561848656816661065088789701201682837073071502397487823
19037
#include <stdio.h>
int a[1001][101]={0};
void add(int n)
{
int k=0,j;
for(j = 1;j<101;j++)
{
k += a[n-1][j] + a[n-2][j] + a[n-4][j];
a[n][j] = k%10000;
k = k/10000;
// printf("%d",k);
}
while(k)
{
a[n][j++] = k%10000;
k = k/10000;
}
}
int main()
{
a[1][1] = 1;
a[2][1] = 2;
a[3][1] = 4;
a[4][1] = 7;
int n,i;
for(i = 5;i<1001;i++)
{
add(i);
}
while(scanf("%d",&n)!=EOF)
{
for(i = 100;i > 0;i--)
{
if(a[n][i]!=0)break;
}
printf("%d",a[n][i]);
for(i=i-1;i>0;i--)
{
printf("%04d",a[n][i]);
}
printf("\n");
}
return 0;
}