HDOJ 1405 The Last Practice

Problem Description
Tomorrow is contest day, Are you all ready?
We have been training for 45 days, and all guys must be tired.But , you are so lucky comparing with many excellent boys who have no chance to attend the Province-Final.

Now, your task is relaxing yourself and making the last practice. I guess that at least there are 2 problems which are easier than this problem.
what does this problem describe?
Give you a positive integer, please split it to some prime numbers, and you can got it through sample input and sample output.

Input
Input file contains multiple test case, each case consists of a positive integer n(1< n<65536), one per line. a negative terminates the input, and it should not to be processed.

Output
For each test case you should output its factor as sample output (prime factor must come forth ascending ), there is a blank line between outputs.

Sample Input
60
12
-1

Sample Output
Case 1.
2 2 3 1 5 1

Case 2.
2 2 3 1

Hint
60=2^2*3^1*5^1

它说的是一些素数!不是全部是素数!既然是从小到大,所以从2开始遍历到根号(n)就可以了。如果最后n还是大于1的,说明n没除完,还剩余一个n^1.

格式!!!
每行的最后一定有一个空格。
各行之间有一个空行!
Case n.!!!数字后面有一个‘.’点。。。

import java.util.Scanner;

public class Main{
    public static void main(String[] args) {
        Scanner sc = new Scanner(System.in);
        int tm = 0;
        while(sc.hasNext()){
            int n = sc.nextInt();
            if(n<0){
                return ;
            }
            if(tm>0){
                System.out.println();
            }

            System.out.println("Case "+(++tm)+".");
            for(int i=2;i<=Math.sqrt(n);i++){
                int num = 0;
                while(n%i==0){
                    n=n/i;
                    num++;
                }
                if(num!=0){
                    System.out.print(i+" "+num+" ");
                }
            }
            if(n>1){
                System.out.print(n+" 1 ");
            }
            System.out.println();

        }
    }

}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值