HDOJ-1010 Tempter of the Bone 【DFS】【奇偶剪枝】

Tempter of the Bone

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 115641    Accepted Submission(s): 31391


Problem Description
The doggie found a bone in an ancient maze, which fascinated him a lot. However, when he picked it up, the maze began to shake, and the doggie could feel the ground sinking. He realized that the bone was a trap, and he tried desperately to get out of this maze.

The maze was a rectangle with sizes N by M. There was a door in the maze. At the beginning, the door was closed and it would open at the T-th second for a short period of time (less than 1 second). Therefore the doggie had to arrive at the door on exactly the T-th second. In every second, he could move one block to one of the upper, lower, left and right neighboring blocks. Once he entered a block, the ground of this block would start to sink and disappear in the next second. He could not stay at one block for more than one second, nor could he move into a visited block. Can the poor doggie survive? Please help him.
 

 

Input
The input consists of multiple test cases. The first line of each test case contains three integers N, M, and T (1 < N, M < 7; 0 < T < 50), which denote the sizes of the maze and the time at which the door will open, respectively. The next N lines give the maze layout, with each line containing M characters. A character is one of the following:

'X': a block of wall, which the doggie cannot enter; 
'S': the start point of the doggie; 
'D': the Door; or
'.': an empty block.

The input is terminated with three 0's. This test case is not to be processed.
 

 

Output
For each test case, print in one line "YES" if the doggie can survive, or "NO" otherwise.
 

 

Sample Input
4 4 5
S.X.
..X.
..XD
....
3 4 5
S.X.
..X.
...D
0 0 0
 
Sample Output
NO
YES
 
 
奇偶剪枝:

        把map看作

                             0 1 0 1 0 1
                             1 0 1 0 1 0
                             0 1 0 1 0 1
                             1 0 1 0 1 0
                             0 1 0 1 0 1

                       从 0->1 需要奇数步

                       从 0->0 需要偶数步
                       那么设所在位置 (x,y) 与 目标位置 (dx,dy)

                       如果abs(x-y)+abs(dx-dy)为偶数,则说明 abs(x-y) 和 abs(dx-dy)的奇偶性相同,需要走偶数步

                       如果abs(x-y)+abs(dx-dy)为奇数,那么说明 abs(x-y) 和 abs(dx-dy)的奇偶性不同,需要走奇数步

                       理解为 abs(si-sj)+abs(di-dj) 的奇偶性就确定了所需要的步数的奇偶性!!

                       而 (ti-setp)表示剩下还需要走的步数,由于题目要求要在 ti时 恰好到达,那么  (ti-step) 与 abs(x-y)+abs(dx-dy) 的奇偶性必须相同

                       因此 temp=ti-step-abs(dx-x)-abs(dy-y) 必然为偶数!

 

代码:

#include <iostream>
#include <cstdio>
#include <cmath>
#define SIZE 10
using namespace std;
int n, m, t;
int step[4][2] = {
    {1,0},{0,1},{-1,0},{0,-1}
};
char map[SIZE][SIZE];
bool vis[SIZE][SIZE];
int sx, sy, dx, dy;
bool escape;
void dfs(int x, int y,int curt) {
    if (x < 0 || y < 0 || x >= n || y >= m)
        return;
    if (map[x][y] == 'X')
        return;
    if ((map[x][y] == 'D'&&curt == 0) || escape) {
        escape = true;
        return;
    }
    // 奇偶剪枝
    int temp = t - abs(sx - dx) - abs(sy - dy);
    if (temp < 0 || temp & 1)
        return;

    vis[x][y] = true;

    for (int i = 0; i < 4; i++) {
        int tx = x + step[i][0];
        int ty = y + step[i][1];
        if (vis[tx][ty] == false && !escape) {
            dfs(tx, ty, curt - 1);
            if (escape)
                return;
        }
    }

    vis[x][y] = false;
}
int main(void)
{
    while (scanf("%d%d%d", &n, &m, &t)!=EOF && n&&m&&t) {
        escape = false;
        for (int i = 0; i < n; i++) {
            scanf("%s", map[i]);
            for (int j = 0; j < m; j++) {
                if (map[i][j] == 'S') {
                    sx = i;
                    sy = j;
                }
                else if (map[i][j] == 'D') {
                    dx = i;
                    dy = j;
                }
                vis[i][j] = false;
            }
        }
        dfs(sx, sy, t);
        cout << (escape ? "YES" : "NO") << endl;
    }
    return 0;
}

转载于:https://www.cnblogs.com/ray-coding-in-rays/p/6403563.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值