A1055 The World's Richest (25 分)(输出给定年龄范围内的财富值从大到小排序的前M人信息)

Forbes magazine publishes every year its list of billionaires based on the annual ranking of the world's wealthiest people. Now you are supposed to simulate this job, but concentrate only on the people in a certain range of ages. That is, given the net worths of N people, you must find the M richest people in a given range of their ages.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers: N (≤10^​5​​) - the total number of people, and K (≤10^​3​​) - the number of queries. Then N lines follow, each contains the name (string of no more than 8 characters without space), age (integer in (0, 200]), and the net worth (integer in [−10​6​​,10​6​​]) of a person. Finally there are K lines of queries, each contains three positive integers: M (≤100) - the maximum number of outputs, and [AminAmax] which are the range of ages. All the numbers in a line are separated by a space.

Output Specification:

For each query, first print in a line Case #X: where X is the query number starting from 1. Then output the M richest people with their ages in the range [AminAmax]. Each person's information occupies a line, in the format

Name Age Net_Worth

The outputs must be in non-increasing order of the net worths. In case there are equal worths, it must be in non-decreasing order of the ages. If both worths and ages are the same, then the output must be in non-decreasing alphabetical order of the names. It is guaranteed that there is no two persons share all the same of the three pieces of information. In case no one is found, output None.

Sample Input:

12 4
Zoe_Bill 35 2333
Bob_Volk 24 5888
Anny_Cin 95 999999
Williams 30 -22
Cindy 76 76000
Alice 18 88888
Joe_Mike 32 3222
Michael 5 300000
Rosemary 40 5888
Dobby 24 5888
Billy 24 5888
Nobody 5 0
4 15 45
4 30 35
4 5 95
1 45 50

Sample Output:

Case #1:
Alice 18 88888
Billy 24 5888
Bob_Volk 24 5888
Dobby 24 5888
Case #2:
Joe_Mike 32 3222
Zoe_Bill 35 2333
Williams 30 -22
Case #3:
Anny_Cin 95 999999
Michael 5 300000
Alice 18 88888
Cindy 76 76000
Case #4:
None

题意:

 给出N(≤10^​5​​)个人的姓名、年龄以及其拥有的财富值,然后进行KK (≤10^​3​​) 次查询。每次查询输出年龄范围在[AgeL, AgeR] 的财富值从大到小前M (≤100)人信息。如果财富相同,年龄小的优先;如果年龄相同,姓名的字典序优先。

注意:

  1. 对给出的所有数据,先根据题中的要求进行排序,优先级依次为:财富、年龄、姓名字典序,然后输出时再去判断是否在年龄区间。
  2. 注意题中M的范围(≤100),故可以采用预处理,将每个年龄中财富前100名之内的人全部存到另一个数组中,后面查询的操作均在这个新数组中进行,这样可以明显降低复杂度,使得K次查询不会出错
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
const int maxn = 100010;

int Age[maxn] = {0};
struct Person{
  int age, worths;
  char name[10];
}ps[maxn], valid[maxn];   //ps 存储所有人的信息;valid 存储各自年龄中财富值在100名之内的人

bool cmp(Person a, Person b){
  if(a.worths != b.worths)
    return a.worths > b.worths;
  else if(a.age != b.age)
    return a.age < b.age;
  return strcmp(a.name, b.name) < 0;
}

int main(){
  int n, k;
  scanf("%d %d", &n, &k);
  for(int i = 0; i < n; i++){
    scanf("%s %d %d", ps[i].name, &ps[i].age, &ps[i].worths);
  }
  sort(ps, ps + n, cmp);
  int validNum = 0;     //存储在valid数组中的人数
  for(int i = 0; i < n; i++){
    if(Age[ps[i].age] < 100){
      Age[ps[i].age]++;
      valid[validNum++] = ps[i];
    }
  }
  int m, ageL, ageR;
  for(int i = 1; i <= k; i++){
    scanf("%d %d %d", &m, &ageL, &ageR);
    printf("Case #%d:\n", i);
    int printNum = 0;
    for(int j = 0; j < validNum && printNum < m; j++){
      if(valid[j].age >= ageL && valid[j].age <= ageR){
        printf("%s %d %d\n", valid[j].name, valid[j].age, valid[j].worths);
        printNum++;
      }
    }
    if(printNum == 0)
      printf("None\n");
  }
  return 0;
}

 

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值