A1024 Palindromic Number (25 分)(大整数加法)

A number that will be the same when it is written forwards or backwards is known as a Palindromic Number. For example, 1234321 is a palindromic number. All single digit numbers are palindromic numbers.

Non-palindromic numbers can be paired with palindromic ones via a series of operations. First, the non-palindromic number is reversed and the result is added to the original number. If the result is not a palindromic number, this is repeated until it gives a palindromic number. For example, if we start from 67, we can obtain a palindromic number in 2 steps: 67 + 76 = 143, and 143 + 341 = 484.

Given any positive integer N, you are supposed to find its paired palindromic number and the number of steps taken to find it.

Input Specification:

Each input file contains one test case. Each case consists of two positive numbers N and K, where N (≤10​10​​) is the initial numer and K(≤100) is the maximum number of steps. The numbers are separated by a space.

Output Specification:

For each test case, output two numbers, one in each line. The first number is the paired palindromic number of N, and the second number is the number of steps taken to find the palindromic number. If the palindromic number is not found after K steps, just output the number obtained at the Kth step and K instead.

Sample Input 1:

67 3

Sample Output 1:

484
2

Sample Input 2:

69 3

Sample Output 2:

1353
3

题意:

定义一种操作:让一个整数加上这个整数首尾颠倒后的数字。例如对于 1257,执行操作就是 1257 + 7521 = 8778,现在给出一个正整数N (≤10^​10​​) 和操作次数K(≤100)限制,问在限定的操作次数内能是否能得到回文数。如果能得到输出那个回文数,并输出操作次数;否则输出最后一次操作得到的数字以及操作次数。

第一次错误原因:

没有在结构体定义中初始化memset, 这样就导致每一次新定义 bign 类型的数据时,可能保存上一次的数据,因此为了方便使用,必须在定义时就用构造函数初始化 bign. 

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <iostream>
using namespace std;

struct bign{
  int d[1000];
  int len;
  bign(){
    memset(d, 0, sizeof(d));
    len = 0;
  }
};
bign change(char str[]){
  bign a;
  a.len = strlen(str);
  for(int i = 0; i < a.len; i++){
    a.d[i] = str[a.len - i - 1] - '0';
  }
  return a;
}

bign add(bign a, bign b){
  bign c;
  int carry = 0;
  for(int i = 0; i < a.len || i < b.len; i++){
    int temp = a.d[i] + b.d[i] + carry;
    c.d[c.len++] = temp % 10;
    carry = temp / 10;
  }
  if(carry != 0){
    c.d[c.len++] = carry;
  }
  return c;
}

bool Judge(bign a){
  for(int i = 0; i <= a.len / 2; i++){
    if(a.d[i] != a.d[a.len - i - 1]){
      return false;
    }
  }
  return true;
}
void print(bign a){
  for(int i = a.len - 1; i >= 0; i--){
    printf("%d", a.d[i]);
  }
  printf("\n");
}
int main(){
  char str[1000];
  int T, k = 0;
  scanf("%s %d", str, &T);
  bign a = change(str);
  while(k < T && Judge(a) == false){
    bign b = a;     //每一次循环都要重新定义b, 必须在结构体定义中初始化bign类型
    reverse(b.d, b.d + b.len);
    a = add(a, b);
    k++;
  }
  print(a);
  printf("%d\n", k);
  return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值