A1097 Deduplication on a Linked List (25 分)(链表处理)

Given a singly linked list L with integer keys, you are supposed to remove the nodes with duplicated absolute values of the keys. That is, for each value K, only the first node of which the value or absolute value of its key equals K will be kept. At the mean time, all the removed nodes must be kept in a separate list. For example, given L being 21→-15→-15→-7→15, you must output 21→-15→-7, and the removed list -15→15.

Input Specification:

Each input file contains one test case. For each case, the first line contains the address of the first node, and a positive N (≤10​5​​) which is the total number of nodes. The address of a node is a 5-digit nonnegative integer, and NULL is represented by −1.

Then N lines follow, each describes a node in the format:

Address Key Next

where Address is the position of the node, Key is an integer of which absolute value is no more than 10​4​​, and Next is the position of the next node.

Output Specification:

For each case, output the resulting linked list first, then the removed list. Each node occupies a line, and is printed in the same format as in the input.

Sample Input:

00100 5
99999 -7 87654
23854 -15 00000
87654 15 -1
00000 -15 99999
00100 21 23854

Sample Output:

00100 21 23854
23854 -15 99999
99999 -7 -1
00000 -15 87654
87654 15 -1

题意:

 给出 N 个节点的地址、数据、指针,然后给出链表首地址。要求去除链表上权值的绝对值相同的节点(只保留第一个),之后把未删除的节点按链表连接顺序输出,接着把被删除节点也按在原链中的顺序输出。

思路:

首先会想到存在两个数组中,但是存在一个问题:当输入一个新的节点时,应该存在那个数组呢?

遇到静态链表按照一定的顺序输出的问题,最佳方案往往是:在结构体中定义order,按照题目的要求给定order的值,排序输出

结构体中定义 order 用来实现删除与不删除节点的区分,因为本题最后要一起输出两种节点的所有信息,即未删除的节点 order 从0开始编号,被删除节点从 maxn 开始编号,order 初始值为 2*maxn。

要按照顺序输出各节点信息,需要对节点进行排序,如上对于 order 值从小到大顺序为:未删除节点、已删除节点、无效节点。同时也要统计未删除、被删除节点的个数,方便输出时的 for 循环。

注意:

  1. 审题不清:未删除与被删除的节点结束时,next 均为 -1
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
const int maxn = 100010;
const int TABLE = 10010;
struct Node{
    int address, data, next;
    int order;
}node[maxn];
bool isExist[TABLE] = {false};
bool cmp(Node a, Node b){
    return a.order < b.order;
}
int main(){
    for(int i = 0; i < maxn; i++){
        node[i].order = 2 * maxn;
    }
    int n, begin, address;
    scanf("%d%d", &begin, &n);
    for(int i = 0; i < n; i++){
        scanf("%d", &address);
        scanf("%d%d", &node[address].data, &node[address].next);
        node[address].address = address;
    }
    int countValid = 0, countRemoved = 0, p = begin;   //未删除的有效节点个数,被删除的节点个数
    while(p != -1){
        if(!isExist[abs(node[p].data)]){
            isExist[abs(node[p].data)] = true;
            node[p].order = countValid++;
        }
        else{
            node[p].order = maxn + countRemoved++;
        }
        p = node[p].next;
    }
    sort(node, node + maxn, cmp);
    //输出结果
    int count = countValid + countRemoved;
    for(int i = 0; i < count; i++){
        if(i != countValid - 1 && i != count - 1){
            printf("%05d %d %05d\n", node[i].address, node[i].data, node[i + 1].address);
        }
        else{
            printf("%05d %d -1\n", node[i].address, node[i].data);
        }
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值