洛谷P1118 [USACO06FEB]数字三角形Backward Digit Su…

题目描述

FJ and his cows enjoy playing a mental game. They write down the numbers from 1 to N (1 <= N <= 10) in a certain order and then sum adjacent numbers to produce a new list with one fewer number. They repeat this until only a single number is left. For example, one instance of the game (when N=4) might go like this:

    3   1   2   4
      4   3   6
        7   9
         16

Behind FJ's back, the cows have started playing a more difficult game, in which they try to determine the starting sequence from only the final total and the number N. Unfortunately, the game is a bit above FJ's mental arithmetic capabilities.

Write a program to help FJ play the game and keep up with the cows.

有这么一个游戏:

写出一个1~N的排列a[i],然后每次将相邻两个数相加,构成新的序列,再对新序列进行这样的操作,显然每次构成的序列都比上一次的序列长度少1,直到只剩下一个数字位置。下面是一个例子:

3 1 2 4

4 3 6

7 9 16 最后得到16这样一个数字。

现在想要倒着玩这样一个游戏,如果知道N,知道最后得到的数字的大小sum,请你求出最初序列a[i],为1~N的一个排列。若答案有多种可能,则输出字典序最小的那一个。

[color=red]管理员注:本题描述有误,这里字典序指的是1,2,3,4,5,6,7,8,9,10,11,12

而不是1,10,11,12,2,3,4,5,6,7,8,9[/color]

输入输出格式

输入格式:

两个正整数n,sum。

输出格式:

输出包括1行,为字典序最小的那个答案。

当无解的时候,请什么也不输出。(好奇葩啊)

输入输出样例

输入样例#1:  复制
4 16
输出样例#1:  复制
3 1 2 4

说明

对于40%的数据,n≤7;

对于80%的数据,n≤10;

对于100%的数据,n≤12,sum≤12345。


又是一道深搜题,又写了一份无任何优化的代码,哭。才20分。

无脑思路:枚举每个位置然后求和。果然TLE

#include<stdio.h>
#include<algorithm>
#include<iostream>
#include<string.h>
using namespace std;

int n, sum;
int ans[14];
int nnn[14];
bool book[11];
int Pascal_trangle[14][14];


bool check()
{
		for (int j = 1; j <= n-1; j++)
			nnn[j] = ans[j] + ans[j + 1];
	
		for (int m = n - 2; m >= 1; m--)
		{
			for (int j = 1; j <= m; j++)
				nnn[j] = nnn[j] + nnn[j + 1];
		}
	if (nnn[1] == sum)
		return true;
	else
		return false;
}

void dfs(int step)
{
	if (step > n)
	{
		//for (int i = 1; i <= n; i++)
			//cout << ans[i] << ' ';
		//cout << '\n';
		if (check())
		{
			for (int i = 1; i <= n; i++)
				cout << ans[i] << ' ';
			exit(0);
		}
	}
	else
	{
		for (int i = 1; i <= n;i++)
		if (!book[i])
		{
			ans[step] = i;
			book[i] = true;
			dfs(step + 1);
			book[i] = false;
			ans[step] = 0;
		}
	}
}

int main()
{
	//freopen("1.txt","r",stdin);
    cin >> n >> sum;
	dfs(1);
	return 0;
}

正确思路:

参考题解:https://www.luogu.org/blog/Chanis/solution-p1118

首先计算出来杨辉三角的第n行的系数,用一个二重循环即可。然后dfs(int step,int tmp) 此处的tmp是一个排列根据杨辉三角的系数计算的和,tmp是随着深度增加而增加的,所以一旦tmp大于目标的和,就可以判定不对(这是一个剪枝)。

#include<stdio.h>
#include<algorithm>
#include<iostream>
#include<string.h>
using namespace std;
int n, sum;
int ans[14];
bool book[14];
int Pascal_trangle[14][14];

void count_Pascal_trangle()//计算杨辉三角的系数
{
	Pascal_trangle[1][1] = 1;
	for (int i = 2; i <= n;i++)
	for (int j = 1; j <= i; j++)
		Pascal_trangle[i][j] = Pascal_trangle[i - 1][j - 1] + Pascal_trangle[i - 1][j];
}


void dfs(int step,int tmp)
{
	if (tmp > sum)
		return;
	if (step > n)
	{
		if (tmp == sum)
		{
			for (int i = 1; i <= n; i++)
				cout << ans[i] << ' ';
			exit(0);
		}
	}
	for (int i = 1; i <= n;i++)
	if (!book[i])
	{
		ans[step] = i;
		book[i] = true;
		dfs(step + 1, tmp + ans[step] * Pascal_trangle[n][step]);
		book[i] = false;
		ans[step] = 0;
	}
}

int main()
{
	//freopen("1.txt", "r", stdin);
	cin >> n >> sum;
	count_Pascal_trangle();
	dfs(1, 0);
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

水之积也不厚,则其负大舟也无力

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值