归并排序求逆序对

One measure of ``unsortedness'' in a sequence is the number of pairs of entries that are out of order with respect to each other. For instance, in the letter sequence ``DAABEC'', this measure is 5, since D is greater than four letters to its right and E is greater than one letter to its right. This measure is called the number of inversions in the sequence. The sequence ``AACEDGG'' has only one inversion (E and D)---it is nearly sorted---while the sequence ``ZWQM'' has 6 inversions (it is as unsorted as can be---exactly the reverse of sorted). 

You are responsible for cataloguing a sequence of DNA strings (sequences containing only the four letters A, C, G, and T). However, you want to catalog them, not in alphabetical order, but rather in order of ``sortedness'', from ``most sorted'' to ``least sorted''. All the strings are of the same length. 

Input

The first line contains two integers: a positive integer n (0 < n <= 50) giving the length of the strings; and a positive integer m (0 < m <= 100) giving the number of strings. These are followed by m lines, each containing a string of length n.

Output

Output the list of input strings, arranged from ``most sorted'' to ``least sorted''. Since two strings can be equally sorted, then output them according to the orginal order.

Sample Input

10 6
AACATGAAGG
TTTTGGCCAA
TTTGGCCAAA
GATCAGATTT
CCCGGGGGGA
ATCGATGCAT

Sample Output

CCCGGGGGGA
AACATGAAGG
GATCAGATTT
ATCGATGCAT
TTTTGGCCAA
TTTGGCCAAA

题解:只有A,C,G,T 四个字母,所以逆序很好求,再用结构体把字符串和逆序连接为一个整体,用sort排序即可;

貌似没有用到归并排序......

代码:

#include <iostream>
#include <string>
#include <cstring>
#include <algorithm>
using namespace std;

struct node
{
    string s;
    int nixu;
};

bool cmp(node x,node y)
{
    return x.nixu<y.nixu;
}
int main()
{
    int n,m;
    while(cin>>n>>m)
    {
        struct node p[100];
        for(int i=0;i<m;i++)
        {
            int a=0,c=0,g=0,t=0,sum=0;
            cin>>p[i].s;
            for(int j=0;j<n;j++)
            {
                if(p[i].s[j]=='A')
                {
                    sum=sum+c+g+t;
                    a++;
                }
                else if(p[i].s[j]=='C')
                {
                    sum=sum+g+t;
                    c++;
                }
                else if(p[i].s[j]=='G')
                {
                    sum=sum+t;
                    g++;
                }
                else if(p[i].s[j]=='T')
                    t++;
            }
            p[i].nixu=sum;
        }
        sort(p,p+m,cmp);
        for(int i=0;i<m;i++)
            cout<<p[i].s<<endl;
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
归并排序是一种经典的排序算法,它通过将待排序列递归地划分成较小的子列,然后将这些子列进行合并,最终得到一个有列。在归并排序的过程中,可以通过统计对的数量来评估列的有程度。 使用归并排序对的基本思想是:在合并两个有列的过程中,如果左子列中的元素大于右子列中的元素,则构成了一个对。在合并过程中,统计对的数量,并将两个子列合并成一个有列。 具体步骤如下: 1. 将待排序列不断二分,直到每个子列只有一个元素。 2. 逐层合并相邻的子列,并在合并过程中统计对的数量。 3. 重复步骤2,直到所有子列合并成一个有列。 以下是使用归并排序对的示例代码: ```python def merge_sort(arr): if len(arr) <= 1: return arr, 0 mid = len(arr) // 2 left, count_left = merge_sort(arr[:mid]) right, count_right = merge_sort(arr[mid:]) merged, count_merge = merge(left, right) return merged, count_left + count_right + count_merge def merge(left, right): merged = [] count = 0 i, j = 0, 0 while i < len(left) and j < len(right): if left[i] <= right[j]: merged.append(left[i]) i += 1 else: merged.append(right[j]) j += 1 count += len(left) - i merged.extend(left[i:]) merged.extend(right[j:]) return merged, count ``` 使用上述代码,可以通过调用`merge_sort`函数来解给定列的对数量。函数返回排序后的列以及对的数量。

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值