题目描述
We have a board with a 2×N grid. Snuke covered the board with N dominoes without overlaps. Here, a domino can cover a 1×2 or 2×1 square.
Then, Snuke decided to paint these dominoes using three colors: red, cyan and green. Two dominoes that are adjacent by side should be painted by different colors. Here, it is not always necessary to use all three colors.
Find the number of such ways to paint the dominoes, modulo 1000000007.
The arrangement of the dominoes is given to you as two strings S1 and S2 in the following manner:
Each domino is represented by a different English letter (lowercase or uppercase).
The j-th character in Si represents the domino that occupies the square at the i-th row from the top and j-th column from the left.
Constraints
1≤N≤52
|S1|=|S2|=N
S1 and S2 consist of lowercase and uppercase English letters.
S1 and S2 represent a valid arrangement of dominoes.
输入
Input is given from Standard Input in the following format:
N
S1
S2
输出
Print the number of such ways to paint the dominoes, modulo 1000000007.
样例输入
3 aab ccb
样例输出
6
提示
There are six ways as shown below:
代码:
#include <iostream> //使用求模运算的性质来实现。
using namespace std;
typedef long long ll;
char arr1[100],arr2[100];
int main()
{
int n;
while(cin>>n)
{
for(int i=0;i<n;i++)
cin>>arr1[i];
for(int i=0;i<n;i++)
cin>>arr2[i];
ll ans=1;
int i;
if(arr1[0]==arr2[0])
{
ans=3;
i=1;
}
else
{
ans=6;
i=2;
}
while(i<n)
{
if( arr1[i-1]==arr2[i-1]&&arr1[i]==arr2[i] )
{
ans=(ans*2)%1000000007;
i++;
}
else if(arr1[i-1]==arr2[i-1]&&arr1[i]!=arr2[i] )
{
ans=(ans*2)%1000000007;
i++;i++;
}
else if(arr1[i-1]!=arr2[i-1]&&arr1[i]==arr2[i] )
{
ans=ans;
i++;
}
else if(arr1[i-1]!=arr2[i-1]&&arr1[i]!=arr2[i] )
{
ans=(ans*3)%1000000007;
i++;i++;
}
}
cout<<ans<<endl;
}
return 0;
}